Topic: Hammerfall Multiface 1

Hi, I have an old, first generation Hammerfall Multiface. Lately I wanted to use it after a longer period and, since I changed my system to Windows 10, I needed new updated drivers. Also, I'm trying to make it through Reaper and it somehow doesn't see anything in the inputs and outputs windows. The host error light is on on the interface. It used to work perfectly well the last time I've used it previously...

2 (edited by MetalHeadKeys 2019-12-21 18:29:21)

Re: Hammerfall Multiface 1

Hi!

Did you update the driver and firmware?

This must be the driver:
https://archiv.rme-audio.de/download/dr … in_429.zip

For the firmware, I'm not so sure. You will have to wait for an RME Support answer.

3

Re: Hammerfall Multiface 1

You updated the OS or  got a new computer?

Regards
Matthias Carstens
RME

Re: Hammerfall Multiface 1

Updated the OS...

Re: Hammerfall Multiface 1

MetalHeadKeys wrote:

Hi!

Did you update the driver and firmware?

This must be the driver:
https://archiv.rme-audio.de/download/dr … in_429.zip

For the firmware, I'm not so sure. You will have to wait for an RME Support answer.

Thank you very much for the driver, that's what I needed... I'm still looking for the firmware update, I don't see it on the web site...

Re: Hammerfall Multiface 1

You 're welcome!

About the firmware, I couldn't find it, either! You will have to wait for MC's answer!

7

Re: Hammerfall Multiface 1

Firmware update is on the old website (Archive/Legacy) and most probably not needed as updated last a long time ago.

Regards
Matthias Carstens
RME

8 (edited by vlado.kuzman 2019-12-23 10:03:28)

Re: Hammerfall Multiface 1

I found the fut_win_dsp.zip package on the legacy site. Downloaded it and tried to run it, but nothing happens. The error light is still on. I'll restart now to see once again did it change anything...
I also found an earlier download, from 2015. Clicked that, it opened up the update window, when I tried to update it it failed several times...

Re: Hammerfall Multiface 1

OK, now I got the firmware update and the latest driver, went through installation and updating, but the error light is still on, is there something I'm doing wrong? I could go through the whole procedure all over again, de installing everything and reinstalling it once again, if that's what it takes, 'cause I finally have all the "ingredients" stored on my computer...

10

Re: Hammerfall Multiface 1

The host LED will only go off if the driver works correctly. So either the driver isn't really working, or the hardware is not working correctly. Also the readme is mentioning that the FUT will only work if the driver is installed (means working). So the firmware update failing is a logical thing until the Mulltiface starts to work.

Regards
Matthias Carstens
RME

11 (edited by vlado.kuzman 2019-12-25 16:17:10)

Re: Hammerfall Multiface 1

Thanks a lot! I've managed to get all the updates needed and I think this https://forum.rme-audio.de/viewtopic.php?id=26602
explains what can be done. I intend to try this procedure once my friend, who is more apt with computer stuff and usually maintains my computer, gets back from holidays. In case it still doesn't do the trick I will ask for some more instructions...

Re: Hammerfall Multiface 1

OK, so I got an old but functional iMac now, with cleanly installed Yosemite 10.10. 5. OS, with the only purpose of recording music. It has the right firewire input and now I need the right driver and firmware to make the interface work: can you give a link to it?

13 (edited by vinark 2020-02-17 22:58:12)

Re: Hammerfall Multiface 1

The multiface is not a FireWire device! Don't connect it to a macs firewire port!!!
It needs a hdsp card, be it PCI PCIe cardbus or expresscard!
Also on windows.

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
HDSP9652+ADI-8AE  2X HDSP9632
Cubase pro10

14 (edited by vlado.kuzman 2020-02-19 09:23:28)

Re: Hammerfall Multiface 1

I used it for years connected only through firewire on windows xp, it worked impeccably...

Re: Hammerfall Multiface 1

It  uses a PCI  card that looks like a firewire card but is not. 100% sure.

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
HDSP9652+ADI-8AE  2X HDSP9632
Cubase pro10

16

Re: Hammerfall Multiface 1

And 100% right. Connection to FireWire immediately kills the Transceivers in it.

Regards
Matthias Carstens
RME

Re: Hammerfall Multiface 1

Ok, so I guess I killed it then when I tried it on a Mac... is there anything i can do? And still how was it possible it worked well through the same port on Windows XP for years, without any external power?

Re: Hammerfall Multiface 1

Then there was a HDSP card in that computer without you knowing it. Would have looked like a firewire card.
If you still have that computer or card you could try out if your multiface is fried. I don't know if there is any chance it is still working. MC does.

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
HDSP9652+ADI-8AE  2X HDSP9632
Cubase pro10

Re: Hammerfall Multiface 1

The same computer that I just put the Windows 10 at, although now it sits at home and I'm in Berlin for another week...