Topic: Help needed with the RME ADI-2 PRO FS R (black edition)

So, I've read the manual and I've tried enough, but I'm having trouble with the following:

I have a set of Genelec speakers with digital in and out's (AES).

I've connected my computer to the RME via a usb cable. No problems getting sound out of my monitors with xlr cables (analogue). Also, the left headphone connector (3/4) also works perfect with my headphones.

Sadly, I can't get the AES to work though.
I've got two DMX - AES XLR male - female cables. Sending one from the RME (toslink) to one monitor (in), and through the out of that monitor to the other monitor. I cannot get any sound that way.

Is there anything I'm doing wrong? If so, a step by step guide to fixing this problem (or setting) would be fantastic. Thanks in advance!

2

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

Your description is confusing. Are you using the Pro's AES XLR out (via breakout cable), or the Pro's optical 'SPDIF' output? In the latter case it might be set to ADAT format.

Regards
Matthias Carstens
RME

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

Sorry for the confusion. I'm indeed using the breakout cable (with all the different connectors) with the AES XLR out.

4

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

In that case you might not be routing anything to the AES output. Can you see a signal in the Global level meter (the vertical meter screen) on the AES output?

Regards
Matthias Carstens
RME

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

But how do I route to AES output? I can see the RME recieves the signal, as the eq's showing all the frequencies moving.

It further says: Main Output 1/2
1/2 -44
3/4 -23.0
INT 44.1

6

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

SETUP - Options - Device Mode / DSD - Digital Out Source: set to Main Out.

Regards
Matthias Carstens
RME

7 (edited by TheBlack 2020-11-28 19:22:37)

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

Did not work, there's no sound going to my monitors.

I've contacted Genelec, wondering if there's something up on that end (GLM maybe).
I'm wondering if the AES cables I am using are correct? It's these: https://procab.be/products/d/prd953---d … --highflex

8 (edited by KaiS 2020-11-29 02:27:11)

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

TheBlack wrote:

I'm wondering if the AES cables I am using are correct? It's these: https://procab.be/products/d/prd953---d … --highflex

The cable is correct.
Is there anything that needs to be switched at the Genelec side?

You said headphone 3/4 has a signal- but main output is linked to headphone 1/2. You need to have audio there too.


Other steps:

Try switching through different "Modes", see manual page 36ff.
I'm mainly using "DAC", page 42.

Still you might need to set clock and AES output source.

9

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

And you didn't answer my question - do the VERTICAL level meters (NOT the Analyzer) show a signal at THE AES OUTPUT? Manual chapter 15.1, Global Level Meter.

Regards
Matthias Carstens
RME

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

At the top it says: Main Output 1/2

At the bottom it does not say AES, but INT.

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

KaiS wrote:
TheBlack wrote:

I'm wondering if the AES cables I am using are correct? It's these: https://procab.be/products/d/prd953---d … --highflex

The cable is correct.
Is there anything that needs to be switched at the Genelec side?

You said headphone 3/4 has a signal- but main output is linked to headphone 1/2. You need to have audio there too.


Other steps:

Try switching through different "Modes", see manual page 36ff.
I'm mainly using "DAC", page 42.

Still you might need to set clock and AES output source.

Thanks for the advice. I've tried switching the modes, to no avail. Sound will not come out through AES, only through analogue XLR. I believe the Main Output might be the problem and have to switch to AES, but I don't know how.

I've tried setthing the Dig. Out Source to Main Out, but it does nothing.

12

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

Go back to that chapter in the manual - you did not call up the Global level meter screen (screenshot there as well). Chapter 5.3 explains how to get there.

Regards
Matthias Carstens
RME

Re: Help needed with the RME ADI-2 PRO FS R (black edition)

Hi there MC, got an answer back from Genelec, and the problem had nothing to do with the ADi-2. It was the GLM software, and I had to adjust some settings. Thank you for having the patience and making the time to help me out. It's highly appreciated!