1 (edited by newidentity 2019-12-10 09:48:07)

Topic: <Solved - (Kind of)> Interface Madness....any wisdom appreciated

Hello. Here’s a problem that has me properly stumped. Any advice from those more knowledgeable would be very welcome.

The characters: Win 10, Cubase 10.5 Pro, Ableton 10, Studio One 4.0 (basic free version), Fireface UCX interface (connected by USB but never at same time as MR816), Steinberg MR816CSX (connected by firewire but never at same time as Fireface), PC (FX8350 8 core 4.0Ghz, 32Gb RAM, SSDs / Raptors and pretty recent fresh install with everything working nicely. Until…

The issue: I have an old project recorded on an old PC (sadly no longer with us) in Studio One Pro 2.0ish via a Steinberg MR816CSX at 88.2Khz/24bit (Firewire). 85 tracks of audio in total (but only a few playing together at once), no plugins, no processing. All fine and playing nicely at time of recording. I now want to work on it in Cubase 10.5 pro on my new PC running an RME Fireface UCX via USB. I drag and drop all the audio files from Studio one project folder into a brand new Cubase project (before I import, I set the Cubase project settings to 88.2khz / 24bit.) Audio imports into separate tracks no problem and all is sounding fine, with CPU / Disk performance always happily bobbing away well below 10%. After 1-2 mins however, glitches, pops and dropouts arrive and over the course of 5-10 seconds, it sputters out into silence. No performance spike, CPU and disk both quite happy at <10% all the way through this. Software seems to keep playing in the background. If I then reset the Fireface sample buffer to any other value (either higher or lower) it fixes everything and it plays again for a min or two before the exact same thing happens – sputters into silence. This happens at any buffer size (even up to 2048), but the performance meters never go above 10%. Exact same thing happens in Ableton 10 after importing the audio from Studio one into a project there, and also in Studio One when I play the original project. All drivers / Firmware are up to date for everything.

During my trouble shooting efforts so far I have discovered:
1)    If I reconnect and use my old MR816 CSX, there is no issue at all in either Cubase, Studio One or Ableton, even at pretty small buffer sizes (128). This is weird as I would have thought RME FF UCX clocking / drivers would be better than the Steinberg MR816’s
2)    When I open the Cubase media Pool, it says the audio files I have imported are 88.2khz 32 bit floating (not 24bit as per both the original recordings AND the way I specifically set the project up before importing into Cubase project – Cubase seems to have forced them into being 32 bit floating). I have no idea what to make of this – can anyone explain this aspect of bit depth to me?
3)    If I then set the Cubase project to either 32bit floating, or just 32 bit, same problem happens, so doesn’t seem to be the issue.
4)    I’ve tried plugging Fireface into all different USB ports (USB2.0 & USB 3.0) – same issue
5)    If I play any other old project in Cubase  (48khz/24bit) – everything is fine, no issues at all.
6)    Have tried disabling all antivirus etc.

I’d be grateful for any wisdom here as my brain is starting to hurt. I can always downsample and work at 48khz but I’m keen to know what the issue is and why a supposedly ‘better’ interface is struggling with this. Anyways, bit of an essay, thanks for taking the time to read and have any suggestions!

2 (edited by newidentity 2019-12-10 09:48:25)

Re: <Solved - (Kind of)> Interface Madness....any wisdom appreciated

Solved - (Kind of)
In case anyone having similar prob, USB seems to be the issue for rme.

When I switch to using the fireface UCX in firewire mode it works fine. Must be some issue with how my PC handles USB lanes. Weird as I did try it in all different USB ports and making sure there was nothing else connected to those ports. Might try getting a dedicated USB PCIE card and see if that avoids the conflict, but for now, its firewire for me...

Re: <Solved - (Kind of)> Interface Madness....any wisdom appreciated

Hello!

Maybe your UCX is in CC mode?
Here's a quote from the manual, if that's the case:

Activation of the Class Compliant mode: Connect the UCX to power and switch it on. Turn the encoder knob in Channel mode until SU appears in the display. Press the knob once to activate Level  mode.  Turn  the  knob  until  CC  is  shown  in  the  display,  then  press  and  hold  the  encoder  until  the  display  shows  on  (pressing  the  knob  again  will  make  the  display  show  oF,  indicating  CC  mode  is  inactive).  The  unit  will  reboot,  all  LEDs  will  light  up,  after  which  it  will  be  in  Class  Compliant mode.

Check if CC mode is active: CC mode is active when turning the encoder lists not only CC, but also C8 and CA in the display.

Also, are you using an external power supply? If you don't, can you try with one connected, as well?

I don't have a UCX(I use a Digiface USB, myself), but after reading the manual, perhaps I can be of some help!

Re: <Solved - (Kind of)> Interface Madness....any wisdom appreciated

Try a new import and watch all settings closely

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
HDSP9652+ADI-8AE  2X HDSP9632
Cubase pro10

Re: <Solved - (Kind of)> Interface Madness....any wisdom appreciated

Weird, replied to this the other day but didnt seem to save
Thanks for replies - tried re-importing (taking care to set at 24bit 88.2) and cubase forces them into 32bit floating in the media pool list despite project remaining at 24 bit 88.2 after import. Very odd.
CC mode wasnt the issue either but good idea - hadnt thought of that.
All working with firewire now so mystery remains. Will post back if I get success with a dedicated usb card.
Thanks again

Re: <Solved - (Kind of)> Interface Madness....any wisdom appreciated

You're welcome!

About bit depth, I think that most DAWs do that internally, so they can have better resolution for their processing. Upsampling is not harmful to your tracks. On the other hand, downsampling might be. That's why dithering is used when you want to export, for example a 44K/24bit to a 44K/16bit track.

Also, did you try with a different usb cable, as well, just to rule that out at least?
Another thing you could try, is Open Device Manager -> USB controllers
Right click on every usb hub(or if you can pinpoint your specific USB port) -> Properties -> Power Mangement and uncheck "Allow computer to turn off this device" option.