1 (edited by mruebsamen 2020-01-13 23:06:06)

Topic: MADIface Pro doesn't work in CC Mode anymore

We have several RME devices (M32 pro, Digiface AVB, ADI 2 -DAC FS and a MADIface Pro). We never had any issues with any of those marvlos devices. However since today our MADIface doesn't work in class compliant mode (for iPhone & iPad) anymore.
As always I first hold the Select & Dim Buttons and add power. As always I can see how the MADIface Pro turned into CC mode. Everything looks normal. But as soon as I plug the USB cable in, the MADIface Pro freaks out. the LEDs start flashing in strange patterns and neither the iPad nor the iPhone can connect. I tried 3 different camera adapter/USB sets as well as 2 different lightning to usb cables (which always worked and still works on the ADI 2 - DAC fs). I tried it on 2 different iPhones and 2 iPads. All the same :-/
Do you have an idea?

By the way: PC mode on my Macs work just normal...


Re: MADIface Pro doesn't work in CC Mode anymore

I can only guess that you use a wrong or broken power supply. In PC mode power will come over USB too, but not so in CC mode with iGadgets...

Matthias Carstens

Re: MADIface Pro doesn't work in CC Mode anymore

You were right. :-)
We have so many wall warts that I wasn't sure which one was the original. Since the MADIface Pro can be powered by USB I was sure that 5 V would be the right voltage. Since it started just normal I was never in doubt that this the right voltage. After changing to a 12 V Adapter, everything works just fine...
But maybe a more specific error code or keeping it of would avoid a situation like this...
Anyways: thank you for your quick help!