1 (edited by ramses 2022-09-10 13:08:27)

Topic: ADI-2 Pro [v116]: CC Mode not properly restored from config

Hi.

I noticed that CC-Mode settings are not properly restored when loading a different setup while USB is plugged.

I thought that unplugging of USB cable is only needed when changing CC-Mode interactively.

This means that a restore cannot be performed fully (including CC-Mode setting) as long as USB is plugged.
I regard this as a bug.

As a workaround, I tried two things
a) to unplug/replug USB in a 2nd step and
b) to power-cycle the device

But in both cases, CC-Mode stays in the wrong state.
Which means, that the config has not been fully restored in terms of CC-Mode.

If at least the config were to 100% recovered—as it should be the case—I could live with it, that a power-cycle is needed to change CC-Mode (if USB is plugged). But currently the config is not fully restored in terms of CC-Mode and this is not so good.

This can lead to confusion, as you think you restored the proper configuration with suitable CC-mode, but in fact CC-mode simply stood in the previous state.

Could you kindly have a look at this, whether this could be solved?

ADI-2 Pro FS R BE, Fw v116.

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro

2 (edited by ramses 2022-09-10 13:13:51)

Re: ADI-2 Pro [v116]: CC Mode not properly restored from config

I think the cleanest solution would be, if the ADI-2 DAC/Pro detected a change of CC-Mode when restoring configs.

And then it is a matter of taste whether the user gets a warning to power-cycle the device to change the CC-mode or whether  ADI-2 DAC/Pro issues a restart immediately.

But as foundation for this it is needed, that the restore of a configuration will be performed fully to 100% in terms of storing the right CC-mode value into the configuration even if a USB cable is plugged.

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro

3 (edited by ramses 2022-09-10 13:19:04)

Re: ADI-2 Pro [v116]: CC Mode not properly restored from config

Furthermore, for interactive configuration of CC-Mode, it should not be locked if USB cable is plugged.
Maybe it would be more useful to issue a message
— that CC-mode has been changed and
— that a power cycle is needed
and a selection box whether to immediately power-cycle or not.

Note: last changes won't be lost, as they are always remembered.

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro

4

Re: ADI-2 Pro [v116]: CC Mode not properly restored from config

For people reading this: it is not about CC-mode as usual, changing from PC to CC mode, but changing between the operating modes 2 channel or 6/8 channel interface. This change is not allowed when being used (=USB connected) for various reasons. And consequently also not part of the Setups, as these would then allow to do the not allowed.

Nevertheless we think the current way can be improved by adding the channel state to the stored Setup, but only loading it when USB is not connected.

Regards
Matthias Carstens
RME

5 (edited by ramses 2022-09-15 12:05:55)

Re: ADI-2 Pro [v116]: CC Mode not properly restored from config

+1

> Nevertheless we think the current way can be improved by adding the channel state to the stored Setup,
> but only loading it when USB is not connected.

Very useful would be to change the mode also during power-cycle.
This is more comfortably than having to unplug the USB cable.

What about remembering a change in a variable, which can be queried after power-up?
Once the CC mode changed (either on power-cycle or USB cable un/replugging) variable could be cleared.

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro