Topic: Linux installation help required

Hi There...

What is the easiest procedure to get HDSP Multiface 1 to work in Linux (Ubuntu Studio 7.04) ???

toni S / Finland

Re: Linux installation help required

Hi toni,

AFAIK, other than making sure you are using an old firmware compatible to Alsa, you just need to launch Synaptic and search for "HDSP", then install the resulting packages.

Jeff Petersen
Synthax Inc.

Re: Linux installation help required

I'm about to give JAD-Audio-Distribution v1.0-RC1 a go !!!

I understand I need to flashback the card to an old firmware on a Windows or Mac computer...
So, I've downloaded the old Flash Update Tool ( … but nothing happens when I doubleclick on the extracted hdsp_fut.exe

Re: Linux installation help required


the fut requires an installed driver.

Daniel Fuchs

Daniel Fuchs

Re: Linux installation help required

Hi Again...

I've got the latest driver (v3.051) installed.

I understand I also need to roll back to an earlier driver version ???

Which one you'd advice ???

toni S

Re: Linux installation help required

Hi There once more...
Back to the Ubuntu Studio 7.04 trail.

Is there any easy way out to get my HDSP Multiface I working under Ubuntu Studio 7.04 ???

The Host error led just stays lid, though the hardware is displayed in the device management ???

I succesfully flashed the card to an earlier firmware ???

I somehow got the HW to work with Ardour 2 GTK under LAD 1 RC1,
but no other applications worked there either.

Simple Guidelines, please.

Thankful for your assistance,
toni S / Finland

7 (edited by independent 2007-09-14 05:41:55)

Re: Linux installation help required

Hello there.
I aren't %100 sure where you're at with the GNU/Linux installation.
Disregarding the last part about getting Ardour to run, I will try and give you some pointers from my perspective.

Ok, have you read this article?
I didn't worry about the asoundrc file or the asound.conf file but the main points about the hdsp system are covered. However it is not apparently clear from anywhere that you need the firmware known as hdsploader, the configuration program hdspconf and the mixer called hdspmixer to get the multiface to function correctly. On top of that you need the hdsp module or compiled into your kernel, this is known as snd-hdsp

Hdsploader is in the alsa-firmware set of packages/programs/equivilent debian/ubuntu deb files. Hdspconf and hdspmixer, I think are in alsa-tools (possibly in alsa-utils, just get them both). Before you try and download the programs go through the steps below to see if they are already in your system. As you are using a multimedia-centric distro like Ubuntu Studio I expect the module to be loaded but perhaps you need to get the rest of the packages.

You may need to get them through synaptic if they aren't loaded already. I don't actually know how the actual packages are configured because I use gentoo and it works very differently to Ubuntu.
To see if the module snd-hdsp is loaded in your kernel; use the command lsmod to look for the it. If it is not there run sudo modprobe snd-hdsp to see if it is available but not loaded. If it is there, in a terminal try running hdsploader as a normal user. If all your lights flash and then disappear, then the firmware has been uploaded and all is working well. If the output of the terminal says there is no such program you will have to get alsa-tools or something similar. If it worked then as a user run hdspmixer.
Something very necessary to realise is that the inputs and outputs are muted if hdspmixer has not been run. Hdspmixer is a clone of Totalmix and although the shortcuts/quick keys are different it is essentially the same, so read that part in the manual (totalmix for windows) to figure out how to use it.