Topic: hdsploader + ubuntustudio 12 + firmware = 'device or resource busy'

greetings!

i have been attempting to configure my hammerfall multiface I with ubuntustudio..

this is what i see when i run hdsploader (after moving the firmware to /lib/firmware/hdsploader/)

hdsploader - firmware loader for RME Hammerfall DSP cards
Looking for HDSP + Multiface or Digiface cards :
Card 0 : HDA Intel at 0xf9ff8000 irq 45
Card 1 : RME Hammerfall DSP + Multiface at 0xfebd0000, irq 17
Upload firmware for card hw:1
Hwdep ioctl error on card hw:1 : Device or resource busy.
Card 2 : HDA NVidia at 0xfbdfc000 irq 17
Card 3 : Akai Akai MPD24 at usb-0000:00:1d.7-5.2, full speed
Card 4 : Creative Technology Ltd. VF0610 Live! Cam Socialize HD at usb-0000:00:1d.7-5.3,

i'm a bit confused why there seems to be an intel and also an nvidia built in soundcard listed.

anyhow, i think i might need to disable pulseaudio to get alsa to function correctly with this card.. does anyone know if that is correct..? and maybe the correct way to do that?

any help welcomed.
thanks

multiface I +pci card
gnu/linux fedora + win 10
https://www.ureka.org

Re: hdsploader + ubuntustudio 12 + firmware = 'device or resource busy'

update: i have updated the alsa firmware package and notice that i am able to see the hdsp card listed in the ALSA soundcard options list (via the multimedia systems selector panel - that i activated in the main menu)..
however, when i click the 'test' button for that soundcard i see: #ALSA — Advanced Linux Sound Architecture: Could not negotiate format#.

so.. not really progress, but at least i can see the card somewhere in linux listed now!

multiface I +pci card
gnu/linux fedora + win 10
https://www.ureka.org

Re: hdsploader + ubuntustudio 12 + firmware = 'device or resource busy'

If resource is busy it could mean firmware is already loaded. Try a shut down (not restart) for a clean reload.
I have posted a recipe for RME + xubuntu which might help out: http://www.rme-audio.de/forum/viewtopic … 108#p86108

/Per

4 (edited by neekos 2013-09-16 17:40:53)

Re: hdsploader + ubuntustudio 12 + firmware = 'device or resource busy'

thanks for the tips @perno

i have now got the rme card to function intermittently. (and i am now using linux mint debian edition instead of ubuntu studio, although i experienced mostly the same issues with both OSs).

i have discovered that the red light on the multiface comes on if i suspend/resume the pc or even 'warm' reboot without a full shutdown and cold boot. so while the card is functional and i can evolve the configuration, the system is not stable.

after uninstalling pulseaudio i setup alsa to use the onboard card for system sounds / browser etc.
and then i am using alsa/jack for other audio apps / sequencers etc.

so far i have used a variety of terminal commands to attempt to re-initiate the rme multiface box once the red light has come on.. and so far i have not found the correct solution.

i have used (in no particular order):

sudo alsa force-reload
hdsploader (shows that the firmware is loaded by saying 'device is busy').
as well as re-loading manually the modprobe snd-hdsp and related other modules.

if anyone has any thoughts as to what is causing this loss of connection between the os and the multiface i would appreciate some tips.. i will probably write a tutorial on this once i fully comprehend the issues since this has been the most lengthy and confused task i think i have ever undertaken with a pc (even more than coding a c++ compiler at university!).

multiface I +pci card
gnu/linux fedora + win 10
https://www.ureka.org

Re: hdsploader + ubuntustudio 12 + firmware = 'device or resource busy'

device busy does mean a other Programm is useing the Card. if you have oss Driver and alsa Driver installed at the same time that could cause the Problem. uninstall oss Driver to see if that solves the Problem.