Topic: RME Babyface pro midi ports don't show in system


I love my babyface pro, it's stable and never caused me any troubles. But the other day when I tried to use Ableton live as a DAW to send midi signals to my synth, I found out I can't get the setting right in Ableton Live's preference.

After searching far and wide, I came to realized that the main problem is because the RME's midi port wasn't listed in Ableton's midi preferences ( like some other interface such as Motu or others...), so I won't be able to choose it in the "external hardware" settings.

So I went to the totalMix setting page, tried to enable the midi port function. Sadly I found out there's no midi port for me to choose, not like the manual instruction.

For now I can hooked up the RME midi port's as a midi input to recieve midi data, but I cannot use it as a midi output to send midi to my hardware synth in my DAW. There's only few discussion about RME's midi port function. So I really hope someone can give me some indication to solve this. Thank you all for reading.

Rme Babyface Pro
Osx: 10.11.6
DAW: Ableton live 10.0.1, LogicX 10.3

Re: RME Babyface pro midi ports don't show in system

Solution replied.

After trying according to this: … he-Mac-OS, I've happily solved the problem.

Turned out that Rme's midi ports have been showed as " Usb midi ports". big_smile