1 (edited by mpc 2021-02-16 21:55:03)

Topic: MADIFX with Wavelab 10 Clocking issue...

Hi.

First post here. I'm stumped about a clocking issue.

I'll try to describe as best I can. MADI (64ch., 96k frame) Firmware v91, Driver 1.25

I'm running a MacPro 2013 OS X 10.13.6, HDSPe MADFX card connected I/O via MADI optical to a Merging Technologies Horus.
In HDSPE settings I'm clocking internally. As a default I generally set my clock to 96Khz.

In Wavelab 10 (latest version) I have two "Audio Montage"'s one at 96Khz and one at 44.1Khz. When I switch montages during my normal workflow...the following happens (or doesn't happen):

I play my 44.1khz montage and I hear a few crackles and within about 6 seconds the Horus switches it's sampling rate from 96khz to 44.1Khz. BUT...in "Clock Mode" in RME HDSPe Settings, the Sample rate stays at 96000hz. In Input Status "MADI 1" changes to 44.khz, 48k frame,  64channels. And TotalMIX FX stays at 96Khz.

I go to my 96khz Audio Montage in Wavelab and things appear normal: It takes about 4 seconds Horus switches it's sample rate
back to 96Khz, MADI 1 in HDSPE Settings goes 96khz,  96k frame and 32 channels. Sample Rate in Clock Mode stays at 96000hz.

So, Horus (via the optical MADI 1 connection I assume) switches sample rates properly when switching between Audio Montages of differing sample rates. BUT, the Clock Mode in HDSPE Settings doesn't change sampling rates? Odd.

If I set the HDSPe Settings Clock Mode to 44100 Sampling Rate (Clock Source still Internal) No Audio plays when I attempt to play a 96khz Audio Montage in Wavelab and about half the time I get spinning beachball requiring a force quit. Horus doesn't switch sample rates.

So, the basic issue is that the MADI FX card isn't switching Sample rate when switching to 44.1khz Montages. Even though audio plays and at the correct speed and pitch, it sort of worries me that some sort of re-sampling is going on? So, it makes me kind of scared about the efficacy of any render I do to 44.1khz audio montages. Now, of course I could manually switch the Sample Rate in Clock Mode, every time I want to play a montage other than 96khz, but that is a real work flow killer. Thanks in advance for the help.

Re: MADIFX with Wavelab 10 Clocking issue...

In HDSPE settings I'm clocking internally.
The basic issue is that the MADI FX card isn't switching Sample rate.
Yes, you told the card using its internal clock instead of syncing.
You load a song into Wavelab for working on it.
That song is produced in a sample rate.
This sample rate should be used everywhere in the system.
Try out madi card clock setting sync to madi and set the clock internal fix in the Horus unit.

OSX M1, Babyface (soundstudio-to-go), started with PST8, Multiface I, Multiface II, PCIeMadi

Re: MADIFX with Wavelab 10 Clocking issue...

Just reinstalled the RME driver. Issue fixed! Now the rme clock switches in sync with the changing sample rate in wavelab.

Thanks.