1 (edited by Dallon426 2021-04-02 15:36:23)

Topic: why is the software clipping?

I have the faders set to 0 and listening to youtube music and it is showing clipping even though the sound signals are at -6

I am curious what settings you guys leave your channel faders on.  Thank you

link here

https://imgur.com/a/i788ROK

RME Babyface Pro, Mac Mini M1 Big sur latest

2 (edited by ramses 2021-04-02 12:27:50)

Re: why is the software clipping?

Sorry, but from your description it is not possible to see why something is overdriven. You talk about channels, faders, but without naming them and the routing concretely.

Which channel/s is/are overdriven ? At a HW input or at a SW playback channel ?

1. A HW Output can easily become overdriven if you route audio from multiple sources as the signals sum up.

2. Maybe Loopback is enabled somewhere .. which sends audio to the corresponding HW input ... But the audio signal is only shown at the HW Output which you are looping back. So if you route such an input channel additionally to an output, then you might overlook the signal ...

It would help if you could post a picture of TotalMix FX that gives the required overview for this szenario.

Thanks

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro

Re: why is the software clipping?

ramses wrote:

Sorry, but from your description it is not possible to see why something is overdriven. You talk about channels, faders, but without naming them and the routing concretely.

Which channel/s is/are overdriven ? At a HW input or at a SW playback channel ?

1. A HW Output can easily become overdriven if you route audio from multiple sources as the signals sum up.

2. Maybe Loopback is enabled somewhere .. which sends audio to the corresponding HW input ... But the audio signal is only shown at the HW Output which you are looping back. So if you route such an input channel additionally to an output, then you might overlook the signal ...

It would help if you could post a picture of TotalMix FX that gives the required overview for this szenario.

Thanks


Hi, the link is there now

RME Babyface Pro, Mac Mini M1 Big sur latest

4

Re: why is the software clipping?

The sound signal is not at -6. That is the RMS or 'more average' level. Peaks are much higher and cause the overload. This again is caused by YouTube playing too loud,. You can reduce that in the Youtube player window itself, or in the second row via TM FX.

Regards
Matthias Carstens
RME

Re: why is the software clipping?

Well, this is strange when I keep the fader in control room at -0.1 it does not clip.  But if it is at 0 it shows as clipping.  Strange.

RME Babyface Pro, Mac Mini M1 Big sur latest

6 (edited by paulnajar 2021-04-03 05:03:02)

Re: why is the software clipping?

Yes they’re know as intersample peaks. If you get more that x full scale samples in a row the meter will rightly display clipping. You can set in preferences how many full scale peaks the meters will call an intersample peak. Youtube and many other internet audio sources are full of them.

Matthias suggested the best remedy - go to the youtube player window and turn the fader down there.

__________________________
Paul Najar
Jaminajar Music Production
www.jaminajar.com

7 (edited by torbenscharling 2021-04-03 18:35:39)

Re: why is the software clipping?

That's why it's suggested to render at max -0.1db or -0.3db preferably, to avoid that nasty stuff smile

8

Re: why is the software clipping?

Well, the nasty stuff won't go away with that - it just doesn't get visible anymore...

Tip: Use DIGICheck level meters and activate the OVS option in the meter settings.

Regards
Matthias Carstens
RME

9 (edited by torbenscharling 2021-04-04 05:30:49)

Re: why is the software clipping?

MC wrote:

Well, the nasty stuff won't go away with that - it just doesn't get visible anymore...

I would think it would go away if it's not re-encoded and you're safe to play it as is, with a player that doesn't digitally gain or otherwise convert, or change that master render..But because of what you mention, I guess that's why many have moved from -0.1db to -0.3db down to -1.0db, cause so much is online now re-encoded constantly..Also one of the reasons mastering engineers talk so much about LUFS etc. because all the streaming stations have their own way of changing the audio before it goes out to the consumer hmm

Ya I'll definitely start using DIGIcheck more !

It'd be cool if you could have all/several functions in one window like say, having the level meter in Totalyser including OVS option, or just include OVS in Totalyser's master level meters..

Cheers smile

10 (edited by kathampy 2021-04-17 06:23:20)

Re: why is the software clipping?

I have this issue only on macOS. The hardware output clips with OVR while the software playback device is at most -0.0 dB with a 0 dBFS test tone, but some music files hit +0.8 dB. In both cases the volume slider in iTunes is at 100%.

I'm not sure how a software playback stream can exceed 0 dBFS in the first place. Maybe Core Audio allows it but WASAPI does not.

On Windows, the output never clips if I route a single software playback device to a hardware output. No single application can exceed -0.0 dB.

11

Re: why is the software clipping?

iTunes does not change sample rates. The resampling in CoreAudio might be a reason.

Regards
Matthias Carstens
RME

12 (edited by kathampy 2021-04-19 20:56:08)

Re: why is the software clipping?

I just discovered that most macOS applications like iTunes and Safari can decode a specially crafted file even at +12 dBFS! There is no internal clipping protection in the decoder. Core Audio apparently allows this clipping by a single application to be "seen" by the hardware. On Windows, this would be hard limited at the application-level stream and the hardware would never clip unless multiple streams are mixed.

The source content is in fact encoded well above 0 dBFS (not just intersample peaks or resampling) and something like ReplayGain is required to avoid clipping.

13

Re: why is the software clipping?

In OS X, Core Audio expects audio data to be in native-endian, 32-bit floating-point, linear PCM format.

https://developer.apple.com/library/arc … Audio.html

Note that this means there is only true 24 bit accuracy. But lots of headroom.

Regards
Matthias Carstens
RME

14 (edited by kathampy 2021-04-20 06:14:37)

Re: why is the software clipping?

MC wrote:

In OS X, Core Audio expects audio data to be in native-endian, 32-bit floating-point, linear PCM format.

https://developer.apple.com/library/arc … Audio.html

Note that this means there is only true 24 bit accuracy. But lots of headroom.

Does this mean that the same media files are silently clipping in Windows at 24-bit integer? If I leave the software playback faders at 0 dB on macOS and let the output clip, will I get the same experience as listening to these files on Windows?

15

Re: why is the software clipping?

Windows audio is known to have no headroom. In fact the last 0.2 dB are kind of clipping limiter. Just search the web...

The remedy is exactly the same for both OS - reduce volume level to prevent overloads.

Regards
Matthias Carstens
RME

Re: why is the software clipping?

In my case, the Cubase mix is at -2db but I am still getting OVR. This is my first day with RME so I may be doing something wrong. I obviously don't want to bring the Cubase mix down, but is there something else I should bring down? Cubase is the only thing I'm sending on this channel, not sure why TotalMixFx would be clipping...

https://imgur.com/a/g6Xuzt0

17 (edited by kathampy 2022-08-30 02:25:54)

Re: why is the software clipping?

alanlindsay wrote:

In my case, the Cubase mix is at -2db but I am still getting OVR. This is my first day with RME so I may be doing something wrong. I obviously don't want to bring the Cubase mix down, but is there something else I should bring down? Cubase is the only thing I'm sending on this channel, not sure why TotalMixFx would be clipping...

https://imgur.com/a/g6Xuzt0

I'm not sure if the TotalMix FX playback meters account for inter-sample peaks. If not, you have some other hidden source adding signal to the mix. WASAPI audio will also be mixed in if some other application is specifically using that device for playback, though it looks like you have a separate "Computer" input for Windows default playback.

In any case, inter-sample peaks can be as high as 10 dB for white noise, and are typically 4 dB for real-world content. Use 24-bit or better and don't be afraid to bring down the mix to -4 dB or below.

Re: why is the software clipping?

kathampy wrote:

I'm not sure if the TotalMix FX playback meters account for inter-sample peaks. If not, you have some other hidden source adding signal to the mix. WASAPI audio will also be mixed in if some other application is specifically using that device for playback, though it looks like you have a separate "Computer" input for Windows default playback.

Correct, I have Cubase on its own channel. Actually my "Computer" output (Youtube, Spotify, etc.) is far below peak and sounds fantastic (I wasn't sure RME could sound so much better but... wow):

https://imgur.com/a/gXDwzbG

kathampy wrote:

In any case, inter-sample peaks can be as high as 10 dB for white noise, and are typically 4 dB for real-world content. Use 24-bit or better and don't be afraid to bring down the mix to -4 dB or below.

I'm already at 24bit 48kHz. I guess I'm not following why Cubase is outputting so high when Windows is outputting so much lower (see new screenshot above). Dropping to -4db does give me the clearance I need which is great. But it sounds like this is something I have to do on every project, including projects I collaborate on? It feels like a hack. I searched for a way to limit Cubase output regardless of project but couldn't find anything. If it's possible that would be preferred for sure.

Just to test, I rendered the -4db output from Cubse and opened it in Ozone standalone to push the limits higher. I routed Ozone to the same "Cubase" channel in TotalMixFX and am not getting any kind of clipping. In this case, TotalMixFX shows the exact same peaks as Ozone... How can I get Cubase to behave like this?

https://imgur.com/a/QAOR9x2

19 (edited by kathampy 2022-08-30 10:16:20)

Re: why is the software clipping?

alanlindsay wrote:

I guess I'm not following why Cubase is outputting so high when Windows is outputting so much lower (see new screenshot above).

If the system volume and application volume are set to 100%, Windows will output exactly the level the WASAPI application sends it except for the last ~-0.2 dBFS which will be hard limited. You will never see an OVER in WASAPI shared mode because of the limiter. If a WASAPI application outputs -1 dBFS, you will see -1 dBFS in TotalMix FX. If you have only a single application playing audio, do not hit the limiter, have the volume at 100%, and have no APOs interfering with the sound, the WASAPI shared mode output is actually bit-perfect.

Cubase is the same, except it can clip because there's no limiter with ASIO and you will see OVER. If the mix is -1 dBFS, that's what you will see in TotalMix FX.

alanlindsay wrote:

Dropping to -4db does give me the clearance I need which is great. But it sounds like this is something I have to do on every project, including projects I collaborate on? It feels like a hack.

This is exactly what everyone should be doing. Everyone else is doing it wrong and mastering too hot when using 16-bit or 24-bit integer bit-depth. You need the headroom for other operations like exporting to AAC / MP3 etc. that will otherwise clip due to approximation.

The only time hot mastering is acceptable is for 32-bit floating point, because the data is not lost above 0 dBFS. If the entire workflow is 32-bit floating point, clipping can be avoided by attenuating the output below 0 dBFS during the final export.

Re: why is the software clipping?

Cubase outputs 32 bit float and that can be way way above 0dbFS. There is no inbuilt limiter and if you want one insert it on the master bus or in studio control room out. Or make sure you never  output above 0dbFS from cubase.
If that is not helping, also make sure you don't have both a master out and a studio out assigned. If they end up on the same output of totalmix levels will be 6db louder.

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
Babyface pro fs, HDSP9652+ADI-8AE, HDSP9632

Re: why is the software clipping?

kathampy wrote:

Cubase is the same, except it can clip because there's no limiter with ASIO and you will see OVER. If the mix is -1 dBFS, that's what you will see in TotalMix FX.

alanlindsay wrote:

Dropping to -4db does give me the clearance I need which is great. But it sounds like this is something I have to do on every project, including projects I collaborate on? It feels like a hack.

This is exactly what everyone should be doing. Everyone else is doing it wrong and mastering too hot when using 16-bit or 24-bit integer bit-depth. You need the headroom for other operations like exporting to AAC / MP3 etc. that will otherwise clip due to approximation.

The only time hot mastering is acceptable is for 32-bit floating point, because the data is not lost above 0 dBFS. If the entire workflow is 32-bit floating point, clipping can be avoided by attenuating the output below 0 dBFS during the final export.

Ok thanks for the explanation, I'm no mastering (or mixing!) engineer so this helps me understand the proper practice.

vinark wrote:

Cubase outputs 32 bit float and that can be way way above 0dbFS. There is no inbuilt limiter and if you want one insert it on the master bus or in studio control room out. Or make sure you never  output above 0dbFS from cubase.

Indeed, adding a limiter also solved the issue. It was not clear to me that Cubase was outputting above 0db when its own meters didn't indicate as much. Both suggestions above have got me into the right place, thank you.

22 (edited by kathampy 2022-08-31 02:33:44)

Re: why is the software clipping?

alanlindsay wrote:

Indeed, adding a limiter also solved the issue. It was not clear to me that Cubase was outputting above 0db when its own meters didn't indicate as much. Both suggestions above have got me into the right place, thank you.

Adding a limiter distorts the audio and should not be used if possible. Identify what is causing the increased signal. The output level should be identical to the mix.

Re: why is the software clipping?

kathampy wrote:
alanlindsay wrote:

Indeed, adding a limiter also solved the issue. It was not clear to me that Cubase was outputting above 0db when its own meters didn't indicate as much. Both suggestions above have got me into the right place, thank you.

Adding a limiter distorts the audio and should not be used if possible. Identify what is causing the increased signal. The output level should be identical to the mix.

When I put Ozone on the master out I can see that is it receiving a peaked signal. Cubase doesn't display these peaks in its default setup (there probably is a way...) so I didn't realize they were happening. In the end, this turned out to be more an issue of how Cubase meters work than anything else. Both Ozone and TotalMixFX were providing a more "honest" picture. Now I know to put a 3rd party meter on the output chain so I can see true peaks.

Re: why is the software clipping?

alanlindsay wrote:

Now I know to put a 3rd party meter on the output chain so I can see true peaks.

Which is exactly what TotalMixFX is doing! smile

Re: why is the software clipping?

alanlindsay wrote:

Cubase doesn't display these peaks in its default setup (there probably is a way...) so I didn't realize they were happening.

After some digging I found the "Master Meter" does, in fact, show the peaks I was looking for. Because I haven't used this before I was relying on the "Stereo Out" channel in the mixer view which is not a true peak meter.

The good news is there were no anomalies in my signal chain, just user error on my part. Now that I know how to read true peak in Cubase everything lines up! Much appreciation to kathampy and vinark for help debugging the situation!

26 (edited by kathampy 2022-08-31 08:01:14)

Re: why is the software clipping?

alanlindsay wrote:
alanlindsay wrote:

Now I know to put a 3rd party meter on the output chain so I can see true peaks.

Which is exactly what TotalMixFX is doing! smile

You can reduce the number of samples required for OVER to 1 in the TotalMix FX settings. Otherwise it will miss some brief clipping.

Re: why is the software clipping?

kathampy wrote:
alanlindsay wrote:
alanlindsay wrote:

Now I know to put a 3rd party meter on the output chain so I can see true peaks.

Which is exactly what TotalMixFX is doing! smile

You can reduce the number of samples required for OVER to 1 in the TotalMix FX settings. Otherwise it will miss some brief clipping.

If you use a limiter in your daw this will give clipping indication on each 0dbFS peak. So I would say 3 is a sensible figure

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
Babyface pro fs, HDSP9652+ADI-8AE, HDSP9632