1 (edited by cjunekim 2021-12-25 18:40:43)

Topic: TotalMix FX constantly writes Note On message to the MIDI out port

Hello

I am using the MIDI output from TotalMix FX to display the fader movement from the totalmix on my other devices. I works okay.

However, I found that totalmix fx constantly floods the midi output port with a specific Note On message.

It's 9F 7F 5A, which means Note On on Channel 16, with Note G9 with velocity 90. This message comes out almost every second.

What is this? Maybe, a ping to keep Mackie Control Device awake? Is there any way to turn it off?

Re: TotalMix FX constantly writes Note On message to the MIDI out port

It's a control to prevent a MIDI feedback loop. I'm not knowledgable enough to know if it can be turned off, but given its purpose I would guess not.

28.7 Loopback Detection
The Mackie Control protocol requires feedback of the received commands, back to the hardware controller. So usually TotalMix will be set up with both a MIDI input and MIDI output. Unfortunately any small error in wiring and setup will cause a MIDI feedback loop here, which then
completely blocks the computer (the CPU).
To prevent the computer from freezing, TotalMix sends a special MIDI note every 0.5 seconds
to its MIDI output. As soon as it detects this special note at the input, the MIDI functionality is
disabled. After fixing the loopback, check Enable MIDI Control under Options to reactivate the
TotalMix MIDI.