1 (edited by vincentzaalberg 2022-08-28 09:36:43)

Topic: Loopback

Hi guys,

https://www.rme-audio.de/totalmix-fx-re … ounds.html
In this video RME shows how to loopback and record multiple channels to one stereo input.

I'd like to do this for a somewhat elaborate miced guitar setup with multiple amps, recording 4 or 6 mics to a single stereo track in Logic Pro.

I have obviously read the Totalmix FX manual and for several days tried to setup Totalmix as shows in the video guide.
Sadly I have not been able to replicate this loopback routing and record multiple tracks to a single stereo track (ADAT 7-8).
I'll link a screenshot underneath of my Totalmix routing in good hope of some advice on how to get this routed properly.
https://app.box.com/s/iivtah4qnuammaom5fejzv6hujrbrusy

Thanks in advance!

Vincent

2 (edited by ramses 2022-08-28 10:41:46)

Re: Loopback

Hi Vincent.

You can do that without any problem, but why? The whole point of working with a recording interface and DAW is to record each track individually and then edit the tracks in the DAW individually before mixing and mastering.

To answer your question, this is easily doable:

1. TotalMix FX: submix mode must be activated.

2. click on a free output to where you can route all recorded audio signals, e.g., HW Output “ADAT 1/2 OUT” (bottom row).

[assumed, that mic gain has already been set to reasonable values for each of the mic input channels, if you have an RME Recording interface with Autoset feature, then you can use “Autoset” to find a suitable input gain (+)]

3. pull up the faders of the microphone inputs so far that the levels are about the same and the HW Output “ADAT 1/2 OUT” with the submix from the 4-6 signal sources is not overdriven.

4. If you route mono signals to a stereo output, you can distribute the signals in the stereo panorama by turning the panorama knob of each Mic Input (-> HW inputs, top row).

5. At the HW Output “ADAT 1/2 OUT” (bottom row) you will find a tool/wrench symbol. Click on it and activate Loopback. This will connect the output signal to the corresponding Hardware Input “ADAT 1/2 IN” (top row).

6. In Logic, you can now record the submix of HW Output ADAT 1/2 via HW Input ADAT 1/2.

(+) Please indicate in your forum signature which RME device you own, thank you.

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro

3 (edited by vincentzaalberg 2022-08-28 14:44:00)

Re: Loopback

Hi Ramses,

thanks for your response.
Ah sorry I will adjust my profile later, but I am using a RME Babyface Pro FS with a Focusrite Liquid Saffire 56 connected via ADAT cables.
As to why I want to have this routing recorded instead of having control over 4 or 6 separate tracks: workflow speed and simplicity for fast jobs.

Your steps make total sense to me. In my mind they are the same as in the video guide and manual and yet I cannot get it to record any signal in Logic Pro. I am obviously overlooking what I am doing wrong here. Maybe you can take a look at the screenshot in Drop Box I linked and see if you can comment on it?

Re: Loopback

At HW input ADAT 1-4 there are no audio signals visible. Are the clocks properly synchronized?
Which device is clock master, which clock slave? How is the cabling?

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro

Re: Loopback

Okay, I linked a new screenshot with how Totalmix looks when you see the incoming signals.
As you can see I am trying to route inputs AS 1, AS 1, ADAT 3, ADAT 4 to outputs ADAT 7/8 and recording input ADAT 7/8 in Logic Pro. But so far no signal in Logic Pro.

The RME and Focusrite audio interfaces are connected via 2 ADAT cables, OUT to IN and IN to OUT. The Focusrite is set to master and shows synchronised on it's driver when connected to another computer. The RME is set as slave. I'll link a screenshot of the RME's Fireface USB settings as well.

Normal single channel recording works fine. It's the loopback I'm having trouble with. Any clues when you see these?

Totalmix signal: https://app.box.com/s/oqeo3iuagbuia5afhoejkigpj88b0pra
Fireface USB settings: https://app.box.com/s/nod0mnx4nsui18yvyj57wruawb3vvqhi

Re: Loopback

Clock settings look fine, TM FX looks fine.
In TM FX, you could try to set HW input ADAT 7/8 to stereo (but I think this is not the root cause).
I don't know logic…

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro

Re: Loopback

Oh dear, it looks like I'm even further into the woods than I thought. The Babyface was only working and recording single tracks in OBS but not at all in Logic Pro. So never mind Loopback, I need to fix single track signal routing in Logic first. The Babyface is selected in Logic's prefs though so I'm at a loss here. I bet the moment I get single track signal working in Logic the Totalmix Loopback function will also work. Thanks so far Ramses!

8 (edited by vincentzaalberg 2022-08-29 09:01:13)

Re: Loopback

Goodness. Never bring a new piece of gear to a gig. That's the golden rule right. Turns out right time and time again.

I figured it out. On the Babyface there is a hardware button for toggling between native inputs 1/2 or 3/4 or OPTO!
Now I thought this was just a switch for appointing the big rotor wheel to the level of either of these three. But it seems to function as true input selection switch.

Totally lame I overlooked this as I am obviously not yet used to the RME. But that exposed the issue. Once set to opto input both single track and loopback translates to Logic Pro. Hope this tread will at least serve some other new users as well.

Thanks for being a beacon Ramses!