1 (edited by FredL 2023-05-25 21:41:46)

Topic: [Solved] No TotalMix or headphones on Mac Babyface Pro

Hi, all -I'm having what seems to be a common and ongoing problem with my new Babyface Pro FS on Mac,  one which purportedly was "solved' by others after reinstalling the computer's operating system. I'm not going to do that, but I'm willing to correct any user errors I may be making in order to try to discover the positive attributes so many have associated with this interface.

I've sent a support request, but thought this might be faster. Here are my symptoms: TotalMix sees no devices and won't open a window.  I can add my interface as an offline device and open a mix window, but nothing seems to happen from there.

The headphone outs do not function, but I have output to monitors. From Totalmix I can put the interface in in DAW only mode and record and instrument signal. The SM7b barely made a waveform, expected since I couldn't turn on the mic-pre via Total mix.

In Mac's sound panel the babyface is selected. In audio devices under Mac's audio midi setup I see the Babyface (and serial#) with format options via dropdown. Sliders are grayed out.

Here's the road I've travelled: Background: Running Mac OS Monterey on 4.2 GHz Intel i7 iMac 64 gb ram

I have updated flash
then installed driver 328b2 and driver 4082. I reinstalled them. Restarted etc.

I gave full disk access to fireface usb settings and Totalmix
1.83 for mac (note I did this by adding the applications manually because I didn't see an "allow RME GmbH option originally, but I reinstalled the driver, saw that and allowed it. No change though.

From a forum suggestions I ran this in terminal with the following lack of results:

redacteduser$ /usr/sbin/spctl kext-consent add 67AK2U2X7M
spctl: failed to store new configuration.
Big-imac-5:~ redacteduser$ /usr/sbin/spctl kext-consent list
spctl: no kext consent configuration found.

One last question: The control wheel doesn't have a press and click function, does it, just turning? I thought I read a suggestion to access other functions by pushing it, but they may have been talking about the old babyface or some other RME product. Thanks for your patience (I'm out of it myself, right now haha) Any suggestions welcome!

2 (edited by oli77sch 2023-05-25 22:01:42)

Re: [Solved] No TotalMix or headphones on Mac Babyface Pro

Maybe your Babyface pro FS is in class compliant mode? In this case it would behave as described (so it works as audio device but is not recognised by TotalMix). Plug it out once, press and hold the two buttons 'select' and 'dim' while plugging it in / power it up again. The LED stripes should show 'PC' for a moment, then is it in native driver mode. When it shows 'CC' it's class compliant.
Control wheel: no push function!

UCX - FF 400 - Babyface pro - Digiface USB - ADI-2 (original)
Mac mini M1 - Macbook pro - iPad Air2

Re: [Solved] No TotalMix or headphones on Mac Babyface Pro

You mighty beast, you! Headphones out are working, TotalMix is open and showing levels. Audio is going into Logic Pro; Thanks you for saving me a lot of time and frustration! Now back to my learning curve. Thanks again.

Re: [Solved] No TotalMix or headphones on Mac Babyface Pro

I know, I know, it’s ok, thanks for the flowers…
(joking mode off now)
I ask myself why your unit was in cc mode?
And concerning the SM7b: this one needs lots of gain. No problem for the preamps in the BFproFS!
Have fun!

UCX - FF 400 - Babyface pro - Digiface USB - ADI-2 (original)
Mac mini M1 - Macbook pro - iPad Air2