Topic: Ethernet problem

Hi,
 
My FireWire is connected to an Apple Macbook and TotalMix FX was working fine on my iPad until… I connected my MacBook to Ethernet. Then, TotalMix reported the FireWire was off line. Disconnecting the MacBook so returning to WiFi everything works fine again.

???

2 (edited by waedi 2024-04-09 16:04:03)

Re: Ethernet problem

What interface is this ?
Is it connected with a firewire cable to a firewire port or with an USB cable to an USB port ?
The ethernet connection on the other side is connected to the internet ? Then the Macbook switching automatic from Wifi to ethernet and the Totalmix from the iPad can't see the Macbook, thats normal, they have to be in the same network.
This Totalmix on the iPad is this Totalmix remote app ?
Totalmix on the Macbook is working fine, right ?

M1-Sonoma, Madiface Pro, Digiface USB, Babyface silver and blue

Re: Ethernet problem

OK…

MacBook Air M2 with 2 USB-C ports, network over WiFi
Running TotalMix FX
Fireface UCX II connected to 1 USB-port
No docking station connected
iPad running TotalMix FX Remote
All OK, except on my iPad I see 2 Firefaces: one with a real serial number, the second with number 12345678

Connect Caldigit TS3 Plus docking station to second USB-port on Mac
All Ok

Connect Ethernet cable to the Caldigit dock
Now Totalmix FX Remote on my iPad shows ‘No UDP data received at all.’ and the status is altering between ‘connected’ and ‘offline’. It doesn’t work.

Turned off WiFi on my Mac
The real FireFace on my iPad disappeared, only the ‘12345678’ remains in the list.
It does not work.

Enabled WiFi on the Mac again.
It does not work.

Disconnected Ethernet cable from the Mac.
It works again.

Could it be Totalmix FX Remote can only communicate with the host over WiFi?

Serge

4 (edited by oli77sch 2024-04-10 22:48:57)

Re: Ethernet problem

Serge.Nelissen wrote:

Could it be Totalmix FX Remote can only communicate with the host over WiFi?

Host and remote have to be in the same network. Either WiFi or ethernet. Maybe your Mac has a different IP address over ethernet cable, so you have to search and add it again I think.

FF 400 - Babyface pro - Digiface USB - ADI-2 (original)
Mac mini M1 - Macbook pro - iPad Air2

5 (edited by waedi 2024-04-10 23:17:08)

Re: Ethernet problem

Serge.Nelissen wrote:

Could it be Totalmix FX Remote can only communicate with the host over WiFi?

Serge

Not Totalmix Remote is the problem, the iPad is on Wifi and the mac not when the dock is connected to the ethernet

MacOS system preferences
Network
button with the three dots
change order of the services

Move WLAN up to be the first place.
By default Wifi (WLAN) is on the last place because the other connections ethernet and thunderbolt have better bandwith and stability. In your scenario you want to have the Mac keeping the WLAN active for the Totalmix remote.

M1-Sonoma, Madiface Pro, Digiface USB, Babyface silver and blue

Re: Ethernet problem

Ah! Of course! I should have thought of that myself. Stupid :-(

Re: Ethernet problem

I did some investigations…

Indeed, WiFi and Ethernet have different IP-addresses.

TotalMix remote was connected to my WiFi-IP-address. In ’Host connection settings’ on my iPad I added the IP-address of the Ethernet network. If I use that one, I can communicate with my iPad.

Still one question remaining: why do I see a connection with my real serial number and one with ‘12345678’ ?

Serge