Topic: DPC latency peaks on Dell Latitude D620

Hello,

I use a Dell Latitude D620 Laptop (WinXP SP3) and a PCMCIA FW card (NEC chip) for Recordings with the FF400.
Unfortunately I had some rare dropouts during some recordings.

Today I ran the DPC latency checker for some time (without the PCMCIA card and thus without the FF connected) and discovered some rare Peaks of more than 16000?s = 16ms!!
After each initieal Peak there is a second peak exactly 30s later, which is around 8000?s.

Besides of these peaks the DPC performance is under 100?s.
However during some more testing I found out that the DPC Latency gets higher when browsing through the file system (windows explorer) but stays well below 1000?s.

Has anybody similar problems? Or an idea which driver or other device might cause these problems?


Thanks for any help,
viper

2

Re: DPC latency peaks on Dell Latitude D620

You should do some Google search on this. Dell is well known for Speedstep and CPU fan control down to their BIOS to cause trouble like this. Sometimes there is a solution, sometimes it's just goodbye - hello new one...

Regards
Matthias Carstens
RME

Re: DPC latency peaks on Dell Latitude D620

I found a lot of such problems concerning Dell Notebooks, but as the DPC peaks on this machine are very rare I am a bit confused and it makes it hard to narrow it down.

Hopefully it works pretty well most of the time, but maybe I will have to say "goodbye - hellow new one..." one day...

Re: DPC latency peaks on Dell Latitude D620

Try disabling the trackpad and any USB card reader. Also try disabling the ACPI Battery driver via device-manager. Last but not least WLAN drivers are always a good source of erratic DPC behavior. For example: If you are using an Atheros WLAN device it may poll the connection regulary (every 60 seconds is set as default on bootcamped Macs).

5 (edited by 19 frets 2010-01-25 04:18:45)

Re: DPC latency peaks on Dell Latitude D620

Timur wrote:

Try disabling the trackpad and any USB card reader. Also try disabling the ACPI Battery driver via device-manager. Last but not least WLAN drivers are always a good source of erratic DPC behavior. For example: If you are using an Atheros WLAN device it may poll the connection regulary (every 60 seconds is set as default on bootcamped Macs).

+1

Also disable your blue tooth and use a wired mouse if you have to.  Read up on how to optimize a system for audio recording.  Disable anything you don't need to accomplish your recording.  Use a second external drive for your audio data. I use a Dell laptop and I have everything on it that I don't need for recording disabled.  It took care of all of my issues with drop outs and improved latency.  Hope this helps.

Re: DPC latency peaks on Dell Latitude D620

Well, you don't have to disable everything. Just so much that the DPC peaks vanish. wink

Re: DPC latency peaks on Dell Latitude D620

I already tried to check a lot of things and found out that WLAN is a major problem - but had been disabled for all recordings (as well as bluetooth).
As the peaks are very rare its quite hard to find the bad device.
I will try to check an external hard disk, ACPI, and trackpad next - thanks for the detailed advice!

Re: DPC latency peaks on Dell Latitude D620

How rare is rare? Once every hour perhaps? Try switching SATA controller mode from AHCI to IDE in the BIOS. This helps with some controllers, which produce an hourly dropout otherwise.

Regards
Daniel Fuchs
RME

Regards
Daniel Fuchs
RME

Re: DPC latency peaks on Dell Latitude D620

Thats a good question I can't really answer.
I did two live recordings with this setup, each lasting about 2 hours. And there have been more than one dropout in each recording.
Will change to IDE and make some test recordings during the next couple of days, thanks for the input.

Re: DPC latency peaks on Dell Latitude D620

Hi again!

I seem to have found the bad device. Since I deactivated the PowerMizer (Power control of NVIDIA graphics card) I didn't have a single DPC spike for hours, although WLAN has been switched on and I did a lot of browsing, caused network traffic and so on.
After reactivating the PowerMizer again I did have these peaks again - so I'm very certain that it really is the PowerMizer.

So if anybody has similar problems consider to deactive/test the PowerMizer as well.

Thanks again for your help,
viper