Topic: Fireface 400 - T61 combination not possible?

Hello,

My Setup is:     Fireface 400

                 Thinkpad T61, Dual Core2 Duo T7300 2,0 GHz , 3GB Ram,
                               
                               On board Firewire, Ricoh Controller
                               Alternative: Dawicontrol Firewire Express Card with TI chipset (cardbus seems to be controlled by the Ricoh Chip too)
                                                           
                         
Fireface Setting:          Buffer:   1024 Samples
                           Clock:    Master
         
Tested on windows Xp Pro and Vista Business 32
                           
DAW:  one stereo track is played back in Nuendo 3 or Ableton 7 or Winamp 5.52 (without any plug-in)

The problems I?m facing are two diffrent kinds of errors.  1) Playback is interrupted
                                                           2) squeaking when I move a Window, open a folder or similar, sometimes without doing anything
What I?ve already tried:
-as Playback source I?ve used internal harddrive as well as external Usb harddrive
-I?ve disabled each and every possible device in the Device Manager (Wlan, Lan, Sd Controller, Everything on the same Irq Channel as the Firewire or Expresscard, etc.)
-Fresh OS intallation, always set Cpu Priority on background services
-Dpc Latency Checker shows big drop outs every now and then, at the same time there is the audible error. sometimes there are audible errors, which are?t displayed in DPC nor in the Firefaces Error Display.
-Dpc reports even if I disable nearly the complete Laptop.
- on Vista the noises seemed to be more frequently.
- sometimes i suspected the Nvidia 140 Graphics, because the errors occur (but not only then) when I?m moving a Window rapidly from one side to another. Doing this, I?ve recognized that the CPU rises to 60% Usage due to the window-moving.

I?ve heard that Ricoh is in suspicion or has already been revealed as beiing responsible for those issues.

My first question is, if somebody has positive experience with a T61/Ricoh- Fireface 400 setup?

Second Question would be if I may have hope towards a Cardbus solution (multiface) connecting on the Ricoh controlled cardbus (Expresscard or PcCard) or should I just jump on my brand new Thinkpad t61, cause with Ricohchip I?ve got a all-in-one-not-possible- Solution.

I have no more ideas, so any feedback would be very helpful.

regards,  Tobias

2

Re: Fireface 400 - T61 combination not possible?

Did you try to disable the DVD drive? See threads about the infamous TS-Corp drive:
http://www.rme-audio.de/forum/viewtopic.php?id=1611

Did you check your graphics card power management:
http://www.rme-audio.de/forum/viewtopic.php?id=2004

Did you disable SpeedStep?
http://www.diefer.de/speedswitchxp/index.html

Regards
Matthias Carstens
RME

Re: Fireface 400 - T61 combination not possible?

Thank you very much for your feedback.

my DVD drive is not the Ts Corp. and I?ve disabled it.

I will check out the graphics adapter thing, and the speedstep.

My last try-series was to do all the test on vista. I have to find out how to create a xp recovery media without
this huge package of garbage that comes with lenovos recovery DVD first. Then I will try the above mentioned on XP.

There is no speedswitchvista, right?

is somebody out there, who has a ricoh-fireface 400 setup working?


regards, Tobias

4

Re: Fireface 400 - T61 combination not possible?

Me and one of the programmers have laptops with Ricoh. They work.

Regards
Matthias Carstens
RME

Re: Fireface 400 - T61 combination not possible?

thats surprising for me. Which notebook is it?

Have you done any tweaks, or has it worked from the start?

In five days, in case I don?t find out what to do, I have to return my Fireface to the Trader. The Fireface would have been the perfect solution for me, so
I?m very sad about not finding any remedy.

tomorrow I?ll try Xp installation and nvidia, speedstep tweak.

Re: Fireface 400 - T61 combination not possible?

Nothing, absolutely nothing works.

I?ve tried Speedswitch Xp on maximum Performance. changed my two Ram modules in every possible combination, cause Lenovo proposed it. disabled - enabled every Device in the device Manager. Installed windows hotfix for Firewire. Made chipset update from intel website.
Tested the complete Notebook with Pc Doctor on hardware errors and it "only" says that nvidia Gpu test was a Failure (I?m not shure but I think the Nvidia Quodro 140NVS
has no GPU). Installed OS tree times.

result:  noises, distortion, maximum peak on DPC latency checker, simply when I grab the left side of the task Manager and sway it to and fro.


I?m desperate....

Nobody using a T61 with the Fireface 400 ?.....

7 (edited by tobias 2008-02-27 23:49:49)

Re: Fireface 400 - T61 combination not possible?

I?ve found the powermanager for the graphics card....and surprise, surprise, it seems to help :-)

I?m not very confident at the moment, but tomorow I?ll test it a littler longer.


thanks for the hint with the power management.


is it normal that I get an click (on 256 samples Buffer) when i minimize or maximize  Ableton (playing back one stereo Track)?

8

Re: Fireface 400 - T61 combination not possible?

Yes.

Regards
Matthias Carstens
RME

Re: Fireface 400 - T61 combination not possible?

but this can be avoided (by ableton). sounds like this happens because they reduce the memory usage of the program when minimizing. if they would keep the memory usage the same, this shouldn't happen.

reaper for example got this "fixed" in version 1.867: "minimizing reaper no longer has windows reduce working set (less glitches)"

http://www.reaper.fm
http://www.reaper.fm/download-old-1x.php?skip=20

from this day on i no longer have the glitch when minimizing the application during playback!

10

Re: Fireface 400 - T61 combination not possible?

This glitch may be caused by the graphics action itself, and then I don't think the app can do something against it...but interesting info! We'll check this with DIGICheck.

Regards
Matthias Carstens
RME

11 (edited by Dandruff 2008-02-26 14:48:26)

Re: Fireface 400 - T61 combination not possible?

MC wrote:

We'll check this with DIGICheck.

yeah, digicheck reduces memory usage when minimizing. would be great if you could avoid this (although i don't got any problems/glitches with it yet)! this even should "speed up" digicheck a bit (more responsive on minimize/restore)!



even mozilla's firefox and thunderbird applications support this with an option:

http://kb.mozillazine.org/Config.trim_on_minimize (the latest versions already have this disabled by default)

Re: Fireface 400 - T61 combination not possible?

Dandruff wrote:

but this can be avoided (by ableton). sounds like this happens because they reduce the memory usage of the program when minimizing. if they would keep the memory usage the same, this shouldn't happen.

reaper for example got this "fixed" in version 1.867: "minimizing reaper no longer has windows reduce working set (less glitches)"

http://www.reaper.fm
http://www.reaper.fm/download-old-1x.php?skip=20

from this day on i no longer have the glitch when minimizing the application during playback!

Dandruff wrote:

even mozilla's firefox and thunderbird applications support this with an option:

http://kb.mozillazine.org/Config.trim_on_minimize (the latest versions already have this disabled by default)

Quite interessting! I had the "clicks/pops on graphic action" problem with Live 7 also, and started a thread about that. Will forward the information to ableton, sorry for taking things offtopic. Thanks a lot!

13 (edited by Dandruff 2008-02-26 19:09:12)

Re: Fireface 400 - T61 combination not possible?

no problem. cubase and nuendo (at least the 3.x versions) for example also suffer from this.


btw: this was the original thread at the reaper forums: http://www.cockos.com/forum/showthread.php?t=3809

Re: Fireface 400 - T61 combination not possible?

I also have a Lenovo T61 + FF800 and have basically the same issues. (XP Pro SP2, 2G ram, 2 HD, Nvidia graphics) I am only doing recording and playback, no midi, very few plug-ins, with Reaper. I installed a Siig express cardbus firewire card, but I did not get any performance improvements - the ASIO buffer size is the same as when using the internal 1394 port. Probably because the Ricoh chipset also handles the cardbus, and the minimalist bios is not written for performance.

I have a second SATA hard drive (7200 rpm seagate) for audio files in a bay adapter so it runs via SATA and not USB. This helped a little since the OS/DAW SW and audio data are on different drives. I get all kind of clicking (1394 errors) if I use a USB mouse instead of the touchpad. This is a drag because I want to use a nice big external LCD monitor (so I can see the Reaper screen better) and use a mouse instead of the pad. So I have to live with that for now.

IMO the T61 is a piece of crap. If it didn't belong to my company I would get rid of it. I'll leave my car doors unlocked and hopefully it will be stolen soon. I plan to build a desktop strictly for audio DAW and use the laptop for what it is designed for: web surfing and email.

Re: Fireface 400 - T61 combination not possible?

The results of my troubleshooting are:

After I shut down Powermizer (the energy manager of the Nvidia Quadro 140 NVS) most of the errors in DPC latency are gone and I?ve heard none of the audible errors.

With buffer of 128 Samples I?ve played back 23 Tracks with 23 multiband compressors and several other inserts, plus sned effects on one effectchannel, with no clicks so far.

onboard firewire or TI expresscard-firewire doesn?t seem to make a difference in Performance.

Re: Fireface 400 - T61 combination not possible?

tobias wrote:

The results of my troubleshooting are:

After I shut down Powermizer (the energy manager of the Nvidia Quadro 140 NVS) most of the errors in DPC latency are gone and I?ve heard none of the audible errors.

With buffer of 128 Samples I?ve played back 23 Tracks with 23 multiband compressors and several other inserts, plus sned effects on one effectchannel, with no clicks so far.

onboard firewire or TI expresscard-firewire doesn?t seem to make a difference in Performance.

Hi
I own lenovo R61 and fireface800. I tryed all things said above but I can't get no clicks performance with 128 sampes. Did you do somthing extra then just shot down powermizer?