Topic: HDSP AES-32 on Linux - one device only


I have a new HDSP AES-32 (with 231 firmware) which I would like to use with linux.
(The card works on windows.)

I've tried Debian(Etch, testing and unstable) and Ubuntu 7.04 and 7.10 without much success.

Using the hdspm module in Alsa 1.0.14 which comes with the 2.6.23 kernel-source or later compiling the 1.0.15 drivers produced the same result.

Although the driver loads automatically, only one device with one subdevice can be seen.

$ cat /proc/asound/cards
0 [default        ]: HDSPAES32 - HDSPM MADI
                      RME HDSPM AES32 at 0xf9100000, irq 17
$ cat /proc/asound/pcm
00-00: RME HDSPM AES32 : RME HDSPM AES32 : playback 1 : capture 1

the /proc/asound tree can be found here

Any suggestions what I should try?

Did anyone manage to use this card on linux properly?

Re: HDSP AES-32 on Linux - one device only

Any news on this?
I am also planning to use HDSP AES-32 under linux, as a digital crossover for my active speaker system.
Uli Brueggemann has reported that it works, with driver snd-hdspm. See here: … ssage/1323