1 (edited by joergs. 2019-09-11 13:59:28)

Topic: Fireface UFX driver

Hallo all,
After a system crash of my studiocomputer due to broken RAM I had to rebuild my system from a disc image. Everything is working again except the fireface ufx, connected by firewire.
What I tried:
-uninstall and install the firewire driver
-tested the fireface with my laptop computer, fw and usb connection is fine
-firmware upgrade to fireface
-tried registry clean to delete older entrys

... still not working. In the device manager the fireface does not appear. I can start totalmix from system32 folder, but no window opens.

System is Win7pro, everything worked fine before the crash.

What else can I try?

Re: Fireface UFX driver

Please be more specific about what is not working. Which exact driver have you installed? If you were able to update the firmware, the unit seems to be working.

Daniel Fuchs

Re: Fireface UFX driver

Thanx for your reply.
The firmware update was done with the laptop, which is fully working.
On my studio computer the firewire driver does not appear. Not in the Windows device manager, not in the audio software. The computer can not see the fireface, no Ins and Outs.
Fireface is connected via firewire cable to firewire pci card. FW LED is working at the fireface.

Re: Fireface UFX driver

Can you test USB operation on this PC? Which exact driver did you install? Does the FW card appear in the device manager?

Daniel Fuchs

Re: Fireface UFX driver

Installed the latest FW driver 3.125, also latest Firmware to device.
Altough the firewire card appears in device manager and should work properly I just connected an older Firewire HDD which doesnt work at this PC. It is working on my other systems. So maybe a PCI problem?
Fireface is recognising FW connection, FW LED works. USB driver not tried yet.

6 (edited by jarsrec 2019-10-04 12:48:30)

Re: Fireface UFX driver

I have more or less the same problem. See my detailed description in the forum entry entitled "Removing Old Drivers...". Short version:

-  Installed latest USB driver (driver_usb_win_1168),
-  Installed latest Firewire driver (driver_fw_win_3125)
-  Installed current Firmware (Fireface UFX: USB 360, DSP 163, FireWire 344, Class Compliant 28).

Everything is working fine with USB on my laptop under Windows 8.1, but not so on my main DAW under Windows 10:
-  When connected via USB, Fireface inputs or outputs are not visible/selectable at all, neither in Win Sound Settings, nor in Cubase
-  When connected via Firewire, connections are visible, but when selected, no sound is played back. Actually, I once succeeded in playing back a few seconds, after which it became suddenly silent again. Also, the computer becomes extremely slow, although the CPU load is well below 100%

I have tested both USB and Firewire on my computer with different devices. Both are working as expected, just not with the Fireface UFX.

Please help. I need to get commercial jobs done!
Norbert Eichler (JARS Recording)

Problem solved

Although the Fireface UFX was shown in Device Manager, the 'Device status' said:
"Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)
Object Name not found." I was able to fix it by simply uninstalling the Fireface from within Device Manager (click on the Fireface entry and selected "uninstall device". After a system restart I installed the USB driver once more like I had done a few times before, but this time it installed correctly and I can use the UFX via USB.