1 (edited by TheGroke 2016-04-16 12:06:18)

Topic: Using hardware inserts (send/return) with ProTools and TotalMix FX

Hi. Can someone please outline the steps for using external hardware inserts in TotalMix FX when using Pro Tools PT12. I just don't get it. I want to be able add an insert send return into my PT channel, and ONLY hear the send return signal from the external processor when I'm soloing that channel (and when I'm playing it in the mix for that matter). I can't figure out what settings should be in TotalMix to accomplish this.

In PT with a Digi002 etc, you just add the insert channel and it stops all signal unless you have external gear hooked up. Like on a mixer insert. This is not the case with RME TotalMix.... I can get it to behave this way only if I listen from the hardware input. I just want to be able to hear the effected track as I'm running the mix. Then I can print and fix any delay later.

I promise I have searched every post online for the answer. And I've watched all the videos on YouTube. There are two issues: 1) I'm obviously too dumb for TotalMix 2) Most information online and on YouTube (especially the info from RME) focuses exclusively on TotalMix in isolation from a DAW. But it's the interaction with the DAW that is most confusing for me. How do you integrate the two?

Please help! I need to start mixing some stuff right away.

Thanks,

DT

Re: Using hardware inserts (send/return) with ProTools and TotalMix FX

Maybe I can state this more simply:

How do I add an external hardware insert into Pro Tools using an RME (Fireface 800) in/out? What would the appropriate settings be in TotalMix FX?

Re: Using hardware inserts (send/return) with ProTools and TotalMix FX

Options > Reset Mix > Straight Playback. Then everything is done in the DAW application.

Regards,
Jeff Petersen
Synthax Inc.

Re: Using hardware inserts (send/return) with ProTools and TotalMix FX

Hi Jeff,

Thanks. I've tried this. I'm working on an empty PT12 project except for one single vocal track. I trashed all my PT preferences for a fresh start. I reset TotalMix to Straight Playback. I get signal off the track to my mains when no insert is present. As soon as I add an insert, I hear nothing. What am I doing wrong?

Re: Using hardware inserts (send/return) with ProTools and TotalMix FX

Jeff's suggestion to use Options > Reset Mix > Straight Playback finally worked. I am really not sure what was wrong, but it must have been something to do with my I/Os in PT. I suspected this before, which was why I trashed all my settings - and I had hit default numerous times in my I/Os as well to no avail... but then finally after doing it one time, it worked. Now I can add inserts. Thanks very very much for confirming that Straight Playback should work in this way.

6 (edited by thedukewestern 2020-06-30 02:40:29)

Re: Using hardware inserts (send/return) with ProTools and TotalMix FX

I'm afraid I still don't understand this.  I am pretty familiar with total mix, it seems like the straight playback feature simply zeros out the mixer and outputs so that its "1 to 1" from the software playback layer to the outputs.   I understand that. 

What i do not understand is why pro tools isn't picking up the return?  Signal is getting to my hardware unit just fine, im seeing the meters move etc.   In my setup, I had planned to use analog 4-> output 5 -> compressor.  The signal is getting to the unit just fine via normal totalmix usage.  However,, the signal coming back into input 3 FROM to compressor is not getting back to the track.  This i do not understand.  Where is pro tools looking for the return?  It seems like pro tools is sending it to channel 4, but it isnt returning?



Pro tools says that if it sends the signal out channel 4 (which I am routing to output 5) - that it will look at input 4 for the return.   All of this seems to be lining up just fine. 


update:  Strangely enough... when I insert the send and return into pro tools, I see that the level responds to adjustments on the compressor, when i turn the output all the way down on my compressor, the meter in pt responds to that yet it is inaudible?  So.... I have no idea whats going on.  Anyone haha!

Re: Using hardware inserts (send/return) with ProTools and TotalMix FX

update update...

me: turn low latency monitoring off, you did it correctly. 

Thanks me