Topic: m32AD Pro on Mac question

Hi, I have a Digiface AVB, several Macs and a m32 AD pro.
The connection between the ad32 pro, Digiface AVB and Mac is rocksolid :-)
However for mobile recordings I would like to take as little equipment as possible with me. Macs support AVB. I know that Mac OS 10.13 and 10.14 had some issues but this should have been fixed (with 10.14.4 and above).
When I connect the ad32pro to the ethernet port of any of my Macs the network audio window shows immediately the ad32pro. Audio Midi reports the 32 available channels and when I open logic or any other daw I see all the inputs. However in at least 50% the daw doesn't receive any audio signal. Is there a setting (e.g. stream format) that has to be set right?
Best regards, Marcus

Re: m32AD Pro on Mac question

Am I really the only guy, who has stability issues with RME AVB device and a Mac?

3 (edited by cyrano 2020-06-10 19:55:38)

Re: m32AD Pro on Mac question

There aren't that many of us with an M32Pro out there, yet...

In the case the DAW didn't receive audio, was that on particular machines, or did it refuse in 50% of the cases on the same machine?

In case it's 50% of the Macs, did you check mic settings in System preferences/Security & privacy?

Did it occur on machines with a USB-C to ethernet adapter? Which adapter?

The first generation ethernet to USB-C adapter from Apple was OK. The second one wasn't. It didn't support ethernet booting, or promiscuous mode. Unfortunately, Apple didn't even change product numbers going from gen 1 to gen 2.

Re: m32AD Pro on Mac question

It happens on all machines. Lately it happens more often then it works :-/
It's not such a big issue because we have the Digiface AVB as well. But it is annoying...
It happens on the Mac Pros with built in Ethernet as well as on MacBook Pros with Thunderbolt3 --> Thunderbold2 --> Ethernet adapter...
Sometimes everything works beautifully ... sometimes not :-/

Re: m32AD Pro on Mac question

That's beginning to smell like a defective M32...

Re: m32AD Pro on Mac question

mruebsamen wrote:

Macs support AVB.

While this is correct, it does not guarantee interoperability. To achieve interoperability, vendors have to agree more specifically on what types of streams to support and a whole lot more. MILAN is the most promising common ground, however it is not fully implemented by Apple at this time (even though there is big progress).

For example, the "Acquire Entity" command that macOS sends to the M-32 AD when you check "M-32 AD Pro" in the Audio MIDI Setup > Network Device Browser:

MILAN wrote:

[...the device] shall not implement the ACQUIRE_ENTITY command (NOT_IMPLEMENTED shall be returned).

MILAN does not support that. However, under the hood, macOS* does support different types of stream formats (lately including the MILAN AAF stream formats!), I/O configurations, and other features required by MILAN. Hopefully those will become easily accessible - ie. not requiring terminal commands and a controller app without app icon - with one of the next macOS versions.

We see the MILAN interoperability layer as the only right solution for AVB and cannot implement AVB differently for individual vendors.

Apart from all that - a few notes:
1) are you using a switch or are you connecting directly?
2) could you set the stream formats in the M-32 AD to 8 Ch. AM824 and try again?
3) Who is clock master? Have you tried setting the other entity as master?
4) Since mac does not support 44.1, it all hast to be 48/96/192

Best regards,
Max
--
*with the network adapters that you mention, also the Sonnet Solo 10G after a firmware update that is unfortunately only available for Windows[!]

7 (edited by mruebsamen 2020-07-05 11:52:10)

Re: m32AD Pro on Mac question

Hi Max,
thank you for your answer and sorry for the late reply. I haven't really working with this stuff (due to known reason :-))

ad 1) are you using a switch or are you connecting directly?
directly

ad 2) could you set the stream formats in the M-32 AD to 8 Ch. AM824 and try again?
It took me about 4 hours :-( M-32 kept saying that it is connected on an AVDECC already... after several attempts including the apple avbutil I could set it to this setting. But still the same result: The m-32 received audio but nothing arrived at the daw (I tried logic, dip Quattro & wavelab)

ad 3) Who is clock master? Have you tried setting the other entity as master?
m-32 local, set to 96 kHz

ad4) Since mac does not support 44.1, it all hast to be 48/96/192
this is the first time I hear this. But anyways. I tried it with 96 kHz.

But it found out that it works after using the digiface avb in between (m-32 to digiface avb to mac). I guess the digiface AVB has some healing power :-)
Serious: Now I can hook up the m-32 directly on the network interface on my Mac and it just works... However in between I had the same issues as before. I tried it again with the the digiface avb in between. And now it works again without the digiface avb... this is kind of crazy...

Re: m32AD Pro on Mac question

You can configure the compatibility level of the Digiface AVB either to "Milan" or "IEEE 1722.1". In "IEEE 1722.1" mode it supports static mappings and the ACQUIRE_ENTITY command and is therefore compatible to MAC OS. In "Milan" mode it supports dynamic mappings and CBR (Channel Based Routing). CBR is experimental at the moment.

9 (edited by mruebsamen 2020-11-22 18:31:55)

Re: m32AD Pro on Mac question

I made it :-) months later.
Just for those who would like to hook up a m32ad pro (and I guess the 1610 as well) to a Mac running Catalina or Big Sur without digiface avb.. (Digiface AVB doesn't work with Mac OS Big Sur at the moment...)

1. Decide your Samplerate (48, 96 or 192 kHz)
2. hook up the m32ad pro per ethernet to you avb compatible ethernet port. (Mac Pro trash can support this; otherwise the old thunderbolt to ethernet adapter works as well)
3. Open "Audio Midi"
4. Press cmd-4 --> audio network devices...
5. See if your RME device is there
6. make sure it is not selected (check mark is off)
7. open terminal and write "avbutil --controller"
8.press cmd-2 --> virtual audio configuration
9. select your ethernet adapter with a check mark
10. press cmd-4 --> connection matrix
11. press cmd-3 --> ACDECC controller
12. in AVDECC controller
a) select your Mac
b) in configuration name select: "32 In, 32 Out, 8ch streams" (or whatever fits for you)
c) choose the correct sample rate
d) clock source: Audio Input Stream 1
e) for all input streams "IEC 61883-6 AM8-24 "correct Samplerate"..."
f) Media Clock Input Stream (I didn't manage this but it seems it doesn't have any affects)
g) for all output streams "IEC 61883-6 AM8-24 "correct Samplerate"..."
h) select now in the same window your RME device
i) set the correct sample rate
j) clock source: Internal
k) select for all Input and Outputstreams "IEC 61883-6 AM8-24 sampling rate"
13) See how in the routing matrix window (cmd-4) the routing field turn green
14) right click in  the routing matrix in the right crossing field (e.g. Mac Pro Input Stream 1 / m32ad Output Stream 1) and click the refresh fields
15) check in audio midi, if your Mac is available as an input device
16) open logic or whatever, choose your Mac as an Input device in audio settings
17) choose the right channel
18.) Voila :-)

Actually it should work without the routing. But for me  this was the only way how it worked.
Afterwards everything works flawless (if you keep the sample frequency...)

Best regards, Marcus

10

Re: m32AD Pro on Mac question

Hi Marcus,
thanks for the report!
Some questions:
- you tested this without using a switch, correct? Just a direct connection to the M-32 AD Pro.
- did you try using AAF formats?
- did you try other configurations, ie. with a higher channel count?
Best regards,
Max

Re: m32AD Pro on Mac question

Hi Max,
sorry for late reply... but this always takes some time...

> Some questions:
> - you tested this without using a switch, correct? Just a direct connection to the M-32 AD Pro.
Yes. Direct connection between m32 AD pro and Mac Pro.

> - did you try using AAF formats?
I tried it several times today. In the "AVDECC Einheiten Controller" I could change Input Format to AAF streams for the Mac.
When I tried to change the m32 output streams to this format I always got an error message like: "The Controller sent a command that requires the stream(s) to not be running but there are streams still running." Even though I made sure that the routing matrix has no active routings :-(

> - did you try other configurations, ie. with a higher channel count?
The Mac did let me select higher channel counts (e.g.  64 in, 64 out 8 channel streams or  64 in, 64 out 32 channel streams)
However as soon as I want to set up the m32 AD pro to these settings. I get the above error message :-(
Btw. the Mac seems to be limited to 64 in and 64 out. I didn't find any configuration with 128 ins and out...
Best regards, Marcus

Re: m32AD Pro on Mac question

Hi Marcus,

mruebsamen wrote:

When I tried to change the m32 output streams to this format I always got an error message like: "The Controller sent a command that requires the stream(s) to not be running but there are streams still running." Even though I made sure that the routing matrix has no active routings :-(

I suspect this is due to one of the incompatibilities between Milan and IEEE 1722.1. In short, the sequence of request / response messages during connection management is different, leading to both entities having different state.
A workaround that comes to mind is using Hive. It doesn't enumerate Mac OS as an entity (properly), but shows offline connections on the M-32, which can then be disconnected.

This issue is addressed in the upcoming revision of IEEE 1722.1, so hopefully this workaround will become obsolete soon...

Best regards
Marc

13 (edited by mruebsamen 2020-12-02 11:06:31)

Re: m32AD Pro on Mac question

Hi Marc,
thank you for your post. It helped :-)
Hive on Mac just works together with the m32 AD pro. I tried AAF streams and the IEF... AMO whatever streams and both worked. 
For everybody who uses a Mac:
- just download hive for Mac
- open it and select "Mac native" support from preferences
- wait a second (it takes about 10 seconds until the m32 ad pro shows up
- make sure to use 48, 96 or 192 kHz
- select the same stream formats for the m32 ad pro output streams and the Mac input streams
- click on the correct routing points (Output stream 1 of the m32 to the Input Stream 1 of the Mac and so on)
--> enjoy fantastic sound quality, long and thin cables and a robust connection without additional box :-)

Marcus