Topic: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

Hi everyone,

This morning I have updated the ADI-2 Pro FS R firmware to the lastes version (2021/01/22).
After some audio drops on Mac, I decided to downgrade to an older version (2020/02/07. I thought it was from July).
During the downgrade I think the tool stated 'already up to date', so I decided to check the 'Flash all' and hit upgrade again.
This time a message arose telling it could not be done (don't remember the message).

I switched off and on again.

From this time, when switching on, only the button red light turns to white (and the internal orange lights), but nothing more lights up (not even the screen).
I have uploaded a video to my OneDrive account:
https://onedrive.live.com/?authkey=%21A … mp;o=OneUp

If I connect the ADI-2 PRO to a Mac or windows computer, the ADI-2 Pro is not recognised by the computer, so I cannot try to update firmware again. No 'switch sound' while switching on/off. It takes longer than expected when turning off (from white to red light).

I haven't found any troubleshooting guide where this and other situations are described.

I presume I will have to send it to shop/service, but wanted to know your opinion and if you think of any possible procedure from here.

Any help is appreciated.

Thanks a lot.

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

My opinion : This device must go to RME for EPROM exchange.
The unit does not boot.
The firmware downgrade has ereased the previous software and failed to re-write another one.
You successfully downgraded your device deadly to the ground !

M1-BigSur, Babyface (soundstudio-to-go), started with PST8, Multiface I, Multiface II, PCIeMadi

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

I presume its has to do with that.
Maybe what I did erased both BIOS, so no way to boot.
Maybe only one of the BIOS was erased and I have to do some kind of pushing buttons ritual to boot from the other one smile.

Let's see what other people think about before shop/service ritual.

Thanks waedi

Regards

4 (edited by ramses 2021-02-22 21:35:56)

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

Palikrovol wrote:

This morning I have updated the ADI-2 Pro FS R firmware to the lastes version (2021/01/22).

Strange, I looked around and found no update from that particular date.

The last version of update tool (fut_madiface_mac.zip) for Mac that I found was from 2020-12-15
with an update to version "[...] ADI-2 Pro: 238/98 [...]".

So if your device showed already "v98" on power-up in the display, then firmware was already up-to-date.

I would keep the device in this state now for the time being and wait for RME to reply.

BR
Ramses
X10SRi-F, E5-1650v4, Win10Pro20H2, Cub11Pro, UFX+ (v0.9735), XTC, 12Mic, ADI-2 Pro FS R BE

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

Thanks ramses.

I think the date is the one from the readme inside the .zip file.
But yes, this 2020-12-15 is the last one I used.

I think it is v98, but after the downgrade, no information is shown, so ...

Let's see what RME has to say about it.

Thanks for the info

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

Firmware and driver archives can be for multiple devices.
Its possible that a firmware upgrade utility has nothing for your ADI-2 Pro FS R BE, but an update for another device.
Usually the firmware update tool should show you, whether an upgrade is required.
And if the flashing did not succeed there should be a safety BIOS that should be used on the next boot on.
But as in this case something seems to be strange its best to get in contact with RME.
If you should not hear something through this user form, then you could also try to contact RME by mail:
support@rme-audio.de

BR
Ramses
X10SRi-F, E5-1650v4, Win10Pro20H2, Cub11Pro, UFX+ (v0.9735), XTC, 12Mic, ADI-2 Pro FS R BE

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

Great,

Thanks a lot for the information smile, really appreciated.

Regards

8

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

To be able to flash the unit back to the latest version it must be detected by USB. I am astonished this doesn't work. The white screen is not the problem. Try to reset the unit: hold encoder 1 and the VOL button pushed while turning on the unit. See if it is then found by USB.

Regards
Matthias Carstens
RME

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

Hi Mathias,

It doesn't work.
After reset (1 + vol + turning on) nothing happens, and the device is not recognised.
I have tried in both windows and Mac.

Thanks for the input.
Any other key combination you are aware of?

Regards

10

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

Sorry, no. You will have to send the unit in.

Regards
Matthias Carstens
RME

Re: ADI-2 Pro: Fail to boot after firmware upgrade + downgrade

Thanks Mathias,

I will send an email to support@rme-audio.de as ramses suggested.
I will keep this thread updated with the answer.

Thanks all.