1 (edited by f_leuschner 2021-03-15 14:17:43)

Topic: Loopback & Delay with same source / Syncing Audio and Video [solved]

Hello everyone,

I am trying to sync a camera and a microphone for usage in Skype, using a Babyface Pro.

As I understand (since I cannot choose the channel in Skype, only the device) Skype grabs AN 1/2 automatically.

With the signal routed to my headphones I managed to sync by putting everything through echo.
When I loopback the signal from HW Output 1 back to AN 1/2 I experience an Echo in my test recording, which is quite logical but when I remove AN 1/2 in the submix both signals are gone. Which is also quite logical but I am also quite stuck now.

Screenshot:
https://i.ibb.co/8XY2JTg/Bildschirmfoto-2021-03-03-um-00-11-59.png

Thank you kindly for your help!

Re: Loopback & Delay with same source / Syncing Audio and Video [solved]

May we should find out where the delay is coming from ?
What is delayed then ? The video is delayed and the audio is coming too early ?
How is the camera connected to the computer ?
what camera is it ?
Do you use a USB-HDMI adapter ? Wich one ?
What computer is it ?
Have you a DAW ? You could route the audio signal thru the DAW and use there a delay insert plugin.
On the other hand I think it is possible to do it in Totalmix with some trickery. Loopbacks and Solo...?

M1-BigSur, Babyface (soundstudio-to-go), started with PST8, Multiface I, Multiface II, PCIeMadi

Re: Loopback & Delay with same source / Syncing Audio and Video [solved]

waedi wrote:

May we should find out where the delay is coming from ?
What is delayed then ? The video is delayed and the audio is coming too early ?
How is the camera connected to the computer ?
what camera is it ?
Do you use a USB-HDMI adapter ? Wich one ?
What computer is it ?
Have you a DAW ? You could route the audio signal thru the DAW and use there a delay insert plugin.
On the other hand I think it is possible to do it in Totalmix with some trickery. Loopbacks and Solo...?

Thanks for your quick reply!

• camera is delayed, so audio is coming too early
• camera connection is  Sony Alpha 7C (micro-usb to HDMI) - ATEM Mini Pro - USB-C out - MacBook Pro M1
• adapters have been switched several times, problem persists


• I know that ATEM Mini Pro can add delay on its own audio channels but right now I can’t run the Babyface audio through the ATEM’s mic input.

Re: Loopback & Delay with same source / Syncing Audio and Video [solved]

I'm not a Mac guy, so I'm not 100% sure how it works on one of these ... but can't you just create a loopback on e.g. ADAT 7/8, make a submix on ADAT 7/8 with your microphone input up and use ADAT 7/8 as the input source either in your Audio MIDI Settings or in Skype?

Re: Loopback & Delay with same source / Syncing Audio and Video [solved]

Does the sony not send audio too? I know if it does it will be much worse then a mic through the rme but it might be the only way to have audio and video in sync.
Or it is a different issue! You have to make sure you don't hear the original mic input, by lowering its input fader. You will now hear your voice delayed which is difficult, but in sync with the picture. If this is the case report back.

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
Babyface pro fs, HDSP9652+ADI-8AE, HDSP9632

Re: Loopback & Delay with same source / Syncing Audio and Video [solved]

Hello Vinark and lightbox, thank you kindly!

The camera audio is turned off as I am only using a microphone with the Babyface Pro.
It is not possible to choose a certain input within Skype, only the Babyface as a device - I will try changing the standard input Skype takes within the Audio-MIDI-Setup and the loopback via ADAT 7/8. Will report :-)

Re: Loopback & Delay with same source / Syncing Audio and Video [solved]

Sadly, I am experiencing problems when trying to choose another input within the audio-midi-setup. I can choose from the dropdown menu but the changes made do not stay; this seems to be a known problem with only partial or no real solutions.

Re: Loopback & Delay with same source / Syncing Audio and Video [solved]

Solution:
• Hardware Update of Babyface
• Microphone put into AN 2 instead of 1, fully run through FX with Echo
• Loopback to AN 1 (Skype uses this input by default)

Now I can use the FX signal for Skype and still use my own mix as monitor.

Thanks everyone for the help!!