Topic: Totalmix 1.73 MacOS BigSur graphics bug

I'm running Totalmix 1.73 along an UCX interface (gen1) on a 2020 iMac Retina 5K (new install, latest USB drivers, latest firmware for the UCX). The graphics card in the iMac is the AMD Radeon Pro 5700 8 Go. Whenever the Totalmix window has to be displayed again (for ex. when waking up from sleep, or when enabling/disabling the screensaver, etc...) it is not displayed correctly, but rather like a pattern of scrambled multicolor lines (see attachment).

If the window is moved, or simply resized by its borders, or minimized to the dock and maximized again it does not revert to the normal display (it stays scrambled)

However if I quit Totalmix and launch it again, or if I simply maximize the window (with the green MacOS maximizing button) and minimize it again, it forces a complete redraw and Totalmix is displayed correctly again.

Any clues as why this might happen ?

https://www.dropbox.com/s/d2iwaaf62bnpd … d.png?dl=0
https://www.dropbox.com/s/tya9nlktpipwe … K.png?dl=0

2

Re: Totalmix 1.73 MacOS BigSur graphics bug

Use this version and it should work:

http://www.rme-audio.de/downloads/tmfx_mac_174b2.zip

Regards
Matthias Carstens
RME

Re: Totalmix 1.73 MacOS BigSur graphics bug

Thank you for your quick reply !

I went ahead and replaced my version with the one downloaded from your link but ... same behavior.
By the way it still reads "Totalmix FX Version 1.73" when I display the info from the "About ..." menu.

4 (edited by refugestudio 2021-07-20 08:27:54)

Re: Totalmix 1.73 MacOS BigSur graphics bug

Exactly the same problem here since MacOs 11.4 (I think) and the new version also didn't solve it. I am running a hackintosh which is nominally an iMac Retina 5K, 27-inch, 2019 with Radeon RX 5700 XT 8 GB (actually based on Gigabyte Designare:https://www.tonymacx86.com/threads/succ … .267551/).

My interface is a trusty old Fireface 400.

Re: Totalmix 1.73 MacOS BigSur graphics bug

MC wrote:

Use this version and it should work:

http://www.rme-audio.de/downloads/tmfx_mac_174b1.zip

The ZIP contains the 173 not 174b1, may be a mistake in the rush hour.

M1-BigSur, Madiface Pro, Digiface USB, Babyface silver

6

Re: Totalmix 1.73 MacOS BigSur graphics bug

Uploaded b2 with correct naming. Please try again.

Regards
Matthias Carstens
RME

Re: Totalmix 1.73 MacOS BigSur graphics bug

Unfortunately the b2 version did not work. The TotalMix window is still scrambled after sleep.

Re: Totalmix 1.73 MacOS BigSur graphics bug

Here on M1 Macbook Air BigSur all fine.
The previous version did work well and this one is doing the work.
The issue with the missing top part in full screen mode is still there, not a big problem we can live with that.

M1-BigSur, Madiface Pro, Digiface USB, Babyface silver

9

Re: Totalmix 1.73 MacOS BigSur graphics bug

I can not comment on Hackintoshs. This new version solved the issue for a Mac user, so I expect it to work for those.

Regards
Matthias Carstens
RME

10 (edited by refugestudio 2021-07-21 10:38:02)

Re: Totalmix 1.73 MacOS BigSur graphics bug

I don’t think it’s solved - The thread starter did not yet report back and waedi never had the problem in the first place. Maybe it's related to the type of graphics card, I guess it’s not very common for audio guys. In this case there is really no reason why this bug should be specific to hackintoshs…

11 (edited by asdsorin 2021-07-21 18:44:06)

Re: Totalmix 1.73 MacOS BigSur graphics bug

Hi again Matthias,

I have downloaded the new 1.74 beta 2 version (labeled accordingly now) and replaced the previous version.

Unfortunately....no changes for me, as soon as the screen goes to sleep, the TotalMix window comes back scrambled, just like before the update.

Screen capture links below, with the hardware and software details included, just in case :

https://www.dropbox.com/s/83w3cypl0sprz … g.png?dl=0

Can you reproduce this on your side on a similar configuration ?

12

Re: Totalmix 1.73 MacOS BigSur graphics bug

We have a lot of Macs but none that does this. The user where we could fix it had a Mac Pro. As it is summer holiday time now further versions will take some time to come up.

Regards
Matthias Carstens
RME

Re: Totalmix 1.73 MacOS BigSur graphics bug

I updated to Totalmix 1.74 beta 2 MAC OS X (1) and I'm still getting this problem when my iMac (Retina 5K, 27-inch, 2020) goes to sleep. I'm running macOS Big Sure 11.4.

Not the end of the world (I can fix it by changing the zoom percentage) but would nice to get fixed eventually.

Re: Totalmix 1.73 MacOS BigSur graphics bug

Hi Matthias,

As per your recommandation I have installed the latest version you sent me, TotalMix 1.74v TV3 (test version 3).

The strange behavior is still present...so I'll have to wait for yet another version. No worries, everything else works,
but it's just a bit annoying and "unprofessionally" looking from time to time (even though I only use this iMac at home).

I did get your argument on the holiday time, people have to get a well deserved rest from time to time also, so I'll
just keep playing with the window zoom display ratio, just like AdamBier, in order to get my "healthy" TotalMix display back.
By the way, all this happens whatever the display ratio chosen (from 50%, unusable on an iMac retina display, up to 180%, which makes it look like Grandma's computer !!)

Re: Totalmix 1.73 MacOS BigSur graphics bug

Just an update, this afternoon I used my mac as usual and ... the bug didn't occur, despite several screen saver launches and even after waking from sleep.

I can't understand what happens, I did NOT restart the machine, NOR changed any configuration or installed any software. I have just continued my work starting exactly from the point where I had stopped yesterday (did not even quit some other running apps). Only thing that happened in-between was the long "sleep" period during last night and through the day. Automatic updates are turned off, also.

I'll surely report back if the bug comes back.

PS : Now I see Apple pushes the 11.5 OS update, I'll probably refrain myself for the moment ....

Re: Totalmix 1.73 MacOS BigSur graphics bug

asdsorin wrote:

Just an update, this afternoon I used my mac as usual and ... the bug didn't occur, despite several screen saver launches and even after waking from sleep.

I can't understand what happens, I did NOT restart the machine, NOR changed any configuration or installed any software. I have just continued my work starting exactly from the point where I had stopped yesterday (did not even quit some other running apps). Only thing that happened in-between was the long "sleep" period during last night and through the day. Automatic updates are turned off, also.

I'll surely report back if the bug comes back.

PS : Now I see Apple pushes the 11.5 OS update, I'll probably refrain myself for the moment ....


I did update to that 11.5 and had to reinstall the driver and give OK to these security doors etc. After reboot all works fine again, no issues.

M1-BigSur, Madiface Pro, Digiface USB, Babyface silver