Topic: Ufx+ TB version 44 for windows

I upgraded to version 46 firmware and im having to unplug my tb card when i cold boot windows on my amd system. I didnt have to do this on version 44.. I would like to downgrade to 44 to confirm

im running a 5800 amd chip with a gigabyte alphine ridge card ufx+

thanks

driver archive has only version 42

Re: Ufx+ TB version 44 for windows

Can i please get a answer. When im in version 46 firmware the card gets weird on boots. When im in 42 its fine. This is in window.  Im also running a hackintosh big sur 11.5 on a amd and it worked initial on firm 42 then on 46 it will not show. When i go back to 42 i still cant get the card to work back on the mac.

Ive been thru 3 amd motherboards trying to get this works because i need access to both os platforms for clients. Im getting really burnt of of thunderbolt altogether.

I am currently running the new 570 aero s from gigabyte. Im having excellent audio performance on windows amd outside of seeing the audio card and havign to flip ports or reconnect the cable. I never had any issues like this on my old 370 intel system with the ufx for the last 2 years.

when i was running verison 44 everything was fine. There is something wierd with firmware version 46 and the amd thunderbolt motherboard. Both on windows and mac side.

Please advise

3

Re: Ufx+ TB version 44 for windows

Here are three links to the latest TB versions 105, 108 and 109. We are not aware of any incompatibilities, so your feedback would be very useful about which version does exactly what on which machine.

109 (current from website):
https://www.rme-audio.de/downloads/fut_tb_win.zip

108:
https://www.rme-audio.de/downloads/fut_tb_win_108.zip

105:
https://www.rme-audio.de/downloads/fut_tb_win_105.zip

Regards
Matthias Carstens
RME

4 (edited by 4ccmusic 2021-07-30 17:29:54)

Re: Ufx+ TB version 44 for windows

i just went to 44 and now its working in amd hackintosh, like i suggested before

i can send you the io reg on 44. if you want it on 46 or 42 i can try that, i dont know why this happening. Let me know where to send it

updated..


Ok so i can repro. I have to boot into windows, then into mac and use 44 firmware from rme and i can get it back up by just power cycling on the rme unit

Would this mean its a tb issue, motherboard or rme issue?

The audio performance in this hackintosh motherboard is outstanding. Triggering slate drums kontack accent at 32 buffer. glitch free

5

Re: Ufx+ TB version 44 for windows

Please mention the TB version instead. The DSP version is not unique, 108 and 109 both have 46. So does it mean 109 would work with your reboot trick? And yes, an AMD computer with macOS on it is outside of our support scope. So far 109 works on Windows and (real) Mac computers.

Regards
Matthias Carstens
RME

Re: Ufx+ TB version 44 for windows

105 works on pc and mac with a soft reset

i will try 108 a second time now that i can repro on 105..give me a sec

i installed beta Monterey to double check there was not a corrupt file or some weird bug in big sur and i can again repro 100. Its same situation as big sur. Im running a gigabyte 570s aero g currently and i'm 90 percent sure the same issue happened on the gigabyte vision dp board as well. Its possible gigabyte change some tb setting with the newer boards. These are basically the only amd tb motherboard available on the market outside of intel's line. Im running a maple ridge gigabyte 2.0 thunderbolt card.

again the audio performance is outstanding on this motherboard.  Once i was up i tried a bunch of drum libraries and honestly had the same latency as in windows but with really no cracks or pops. I know in the other thread you mentioned i read up on llm on the ufx +. However,  i do own avid  carbon unit and the dsp is just so low my with mics I only wish I could do the same with my midi edrums and get the timings lower then then 32 buffer. In actually reality, until i can get a sound card to play edrums faster is just easier to play drums with the local sound modules as in my yamaha  dtx 900 because of latency issue as stated by the other drummer in the other thread. A modern sample like slate or accent or dkfh is cool cause the rooms sounds great, but it is ALWAYS LAGGY.

I have no problem making a video to show you all this  . I study tabla, trust me, I know timings.

https://photos.app.goo.gl/bHw1GDV7Z3oVpiX1A
this is on the amd system

Re: Ufx+ TB version 44 for windows

Yeah the problem with 108 is once you shut down the computer, you have to pull the tb cable out to work again..Then on warm reboots its a total headache to get working on either os. So in windows you can pull the cable out and it works but then once you go back to mac its doesn't work..its a headache...i cant tell you more cause im going back to 105

Re: Ufx+ TB version 44 for windows

4ccmusic wrote:

I'm running a gigabyte 570s aero g currently and I'm 90 percent sure the same issue happened on the gigabyte vision dp board as well. It's possible gigabyte change some tb setting with the newer boards. These are basically the only amd tb motherboard available on the market outside of intel's line. I' running a maple ridge gigabyte 2.0 thunderbolt card.

I am using the Gigabyte Thunderbolt Titan Ridge Rev.2 Add-In-Cards (AIC) in the bottom PCIe slots of both the Gigabyte B550 Aorus-Master & a Gigabyte X570 Aorus-Ultra motherboards. As far as I know, only the Gigabyte Titan Ridge thunderbolt add-in cards are officially supported for AMD B550/X570 chipsets.

The Maple Ridge AIC card is officially a Thunderbolt 4 card, certified for use within Intel Z590/B560 chipset series motherboards. Thunderbolt 4 is a different spec with different certification minimum standards. This may cause issues with sleep/restart settings. In addition to this, the fact that you are running these thunderbolt AIC cards within a Hackintosh environment also adds additional complexity to your setup. I'd suggest trying a Titan Ridge Rev.2 AIC TB card and see if that makes a difference.

Re: Ufx+ TB version 44 for windows

I just re-read this thread and see that in your first post you specify an Alpine-Ridge (Intel DSL6540) Thunderbolt AIC, and in your later posts you mention a Maple-Ridge (Intel JHL8540) thunderbolt chipset AIC. You state ver.2 however there is only a rev 1.0 card of the Maple-Ridge chipset card available and it is certified for use on Intel Z590/B560 chipset motherboards. The preferred chipset for B550/X570 AMD motherboards is the Titan Ridge rev 2.0 (DSL7540) AIC card. Which AIC are you actually using and in which slot on your board?

Re: Ufx+ TB version 44 for windows

GIGABYTE GC-Titan Ridge 2.0 (Titan Ridge Thunderbolt 3 PCIe Card Component)

im running that and it is in the last slot with the header.  Your confused because i original had a alpine ridge and i just tried it since i already own one. That alphine ridge is sold...im on version 2 titan ridge with all these issues..