Topic: ADI 2 Pro FS R Black - Relay clicking issue & occasional desync issue?

Hey everyone,
I've owned an ADI 2 Pro FS R Black for about a year and a half now, and have had a somewhat unreliable experience with two odd issues that I've been trying to figure out. I have this device set up in a kind of unique way, so apologies for the big wall of text here!

I'm using this ADI-2 as a set of mastering converters, plugged into a UFX+. Outputs 1-2 are being used as monitor/phone outs, Outputs 3-4 are being used as analog outputs into the mastering chain, and Inputs 1-2 are being used as analog recording inputs from the mastering chain. That makes it work as a sort of 'all-in-one mastering box', giving me good conversion for my monitors as well as one separate set of analog inputs and outputs. It really is a fantastic do-everything mastering converter for these purposes, because it offers high quality conversion for your monitors, as well as separate high quality conversion for a pair of analog inputs and outputs. What would normally require me three AD/DA mastering devices is consolidated into one.

In order to get it working like this, I plugged the ADI-2 into my UFX+ via AES cables, and plugged both the ADI-2 and the UFX+ into the PC separately, via USB. The ADI-2's settings are as follows:

-Main Outputs 1/2 AD/DA Source: AES (From the UFX. This allows the UFX's remote control to work as a volume knob and monitor controller.)
-Main Outputs 1/2 Auto Ref Level: On
-Phones Out 3/4 (Plugged into a Stereo-to-2-Mono splitter cable, then plugged into a Radial JDI to balance the two unbalanced signals): AD/DA Source: USB 1/2
-Phones Out 3/4 Hi Power: On
-Phones Out 3/4 Auto-Ref Level: Off

-Options/Settings - Phones: Dual Phones On. Bal Phones Off. Toggle Ph/Line Off. Mute TRS 1/2 On. Mute TRS 3/4 Off.
-Options/Settings - Device Mode: Basic Mode AD/DA.
-Options/Settings - Clock: Clock Source AES. Sample Rate 88.2 (what I track/mix in most of the time).

With it set up like this, outputs 1-2 always go to monitors. Their volume is controlled via the UFX+ (AES outputs in the UFX are set as the main outputs, and are controlled by the UFX+'s remote). When I plug headphones into Phones Out 1/2 on the ADI-2, it mutes the monitors.

Phones Outputs 3-4 and Analog Inputs 1-2 are used as separate analog inputs and outputs, for sending to and receiving from an analog mastering chain. Analog Inputs 1-2 are accessible via the UFX+ and are labeled as AES inputs.

Phones Outputs 3-4, since their AD/DA source is set as USB 1/2, are accessible differently. This could be where the clocking issues are coming from. So, this ADI-2 is basically connected as two digital devices at once- It is set up as an AD/DA converter connected to the UFX+ via AES cables, which are responsible for Inputs 1/2 and Outputs 1/2, and a DA converter connected directly to the PC via USB, which are responsible for Outputs 3/4.
When I choose "Madiface USB" as my ASIO device in my DAW, the UFX+'s inputs and outputs appear as "Analog 1 (1)", "Analog 2 (1)", "Analog 3 (1)", etc, the  and the ADI-2's outputs 3/4 appear as "Analog 1 (2)" and "Analog 2 (2)".
With as odd as this setup is, it works remarkably well MOST of the time (but not all of the time).

Here's a crude drawing I did of how it is set up:

However, there are a few odd behaviors/glitches that I haven't managed to solve, and was hoping to ask here on the forums if anyone has encountered either of these things.

1. Sometimes, the ADI-2 will fall into a state of crackling/popping upon playback. When it begins to happen, it crackles consistently and frequently- It is not just an odd click or pop every minute or two, but rather, a more constant sound. This happens most often after changing sample rates or buffer sizes, but can sometimes happen just entirely randomly. If I go into the RME settings panel, and change the buffer size 1-3 times, it usually clears up the issue, but not consistently. (It is worth noting that when I change buffer size or sample rate on one RME device, the UFX, for example, the other one follows automatically).

This glitch does not happen very often, but it does enough to be somewhat frustrating when it does, since it can ruin an otherwise decent recorded take. I assume this is a clock desynchronization, since changing the buffer size sort of 'resets' it and clears it up. It does not matter if I change the buffer size to smaller or larger, it is just the change in itself that fixes it.

2. This one feels more like a firmware issue. I certainly hope it's not hardware related. Sometimes, when I unplug headphones into Phones Out 1/2 of the ADI-2, I hear a constant relay clicking noise that does not stop until I turn off the device and turn it back on again. This happens semi-frequently, at least a few times per week. The ADI-2's screen will sometimes dim or flash slightly during this glitch. I have also had this issue happen randomly with only Phones 3/4 plugged in, although this is much less common. Disabling Mute TRS 1/2 on Phones 1/2 made the problem happen less often, but I still had some odd relay clicking bugs from time to time.

At first, I assumed this was a hardware issue, but restarting the device is always able to fix it, so perhaps it is firmware-related. I contacted the support department at the retailer I bought the device at (SX Pro Audio in the UK) and they quoted me something like 5-8 weeks to get it back from RME for repair, which is unacceptable for a device that I rely upon for my work, and unfortunately, I can't afford to just buy a spare ADI-2 to use in the meantime. So, hopefully there's a simpler solution to this issue, instead of spending $2k for a spare one, or waiting 2 months without being able to use mastering converters. It is a bit surprising, as I've owned RME devices for about 10 years now, and the ADI-2 is the first device to give me this much trouble.

Has anyone else experienced either a desync/crackling or continual relay clicking issue with their ADI-2 Pro FS R?

Thanks everyone, much appreciated!


Re: ADI 2 Pro FS R Black - Relay clicking issue & occasional desync issue?

Your setup is correct. The relay click issue is unknown. Check that you use the latest firmware and try a different power supply.

The playback issue needs examination. First make sure both units have the exact same buffer size set in their Settings dialog. Second check the USB error messages in the Settings dialog when that issue occurs. Third also check the current clock state. Are they still in Sync and on the same sample rate?

Matthias Carstens

3 (edited by ramses 2021-12-03 09:22:39)

Re: ADI 2 Pro FS R Black - Relay clicking issue & occasional desync issue?

> With as odd as this setup is, it works remarkably well MOST of the time (but not all of the time).

I have the same setup like you there is nothing odd:
- the two devices connected through USB so that also the ADI-2 Pro can be flashed whenever required
- ADI-2 Pro (clock slave) connected through AES to UFX+ (clock master) in AD/DA mode
- TM FX: assigned UFX+'s AES port as Main Out

Do you use the same drivers and firmware as me ?
I am using MADIface driver 0.9736 and firmware (watch displays when powering on)
- UFX+: software version 46
- ADI-2 Pro FS R BE: v. 102

Your DAW can access both devices directly because both devices are supported by the same MADIface ASIO driver. Only two prerequisites for that:
a) all devices need to be clock synchronized (should be, we check that below)
b) you need to take care in the RME driver settings, that both devices use the same ASIO buffersize

The only little difference in my setup is, that I use on the ADI-2 Pro
     Options -> Device Mode / DSD -> CC-Mode: "Multichannel"
by this I have in the DAW (Cubase 10.5) access to all ports of the ADI-2 Pro.

Check for proper clock synch setup

If you hear clicks and pops occasionally or getting worse then it sounds to me, that there is something like a clock drift going on, which might become worse over time as you say or produce spontaneous clicks and pops. So pls check whether clock synchronization is properly setup:

- UFX+ is clock master in your setup, do you see in the driver settings: clock source = "internal" ?
- ADI-2 Pro in the "State Overview", do you see in the line AES the status "sync" with proper sample rate ?
- as you also connected AES from ADI-2 to UFX+, do you see in the driver settings input status AES "sync" with proper sample rate ?

But it could also be the case that you have USB transport errors.

1. Pls check for USB transport errors
Keep the RME driver settings open, only then the CRC check runs.
Playback Music and observe the CRC counter in the opened settings window.
When you hear clicks and pops, do the CRC counters increase ?

Checks in terms of USB compatibility

Did you read UFX+ manual chapter 40.3 about USB audio and compatibility ? You didn't tell further details of your PC and USB cabling.

What CPU, mainboard, USB chipset do you have ?

Did you try all USB3 ports of your computer to "hopefully" catch a port with a supported and good working USB chipset behind it ?

If you should use something like an USB3 Hub, then please disconnect the UFX+ from that USB hub and connect it directly to an USB3 port of your PC. Please test all USB3 ports. Some might work better (depending on which USB controller is behind it, either from chipset or maybe additionally from a 3rd party USB chipset).

Check for potential load problems

In terms of clicks and pops. It could also be a load problem on your PC or that your computer has maybe too high DPC latencies which could block CPU cores for too long.

Especially in your case as the UFX+ has a high channel count and you told, that you are using higher sample rates at least double speed (88.2).

Does it make a difference if you use higher ASIO buffersizes ?
If you check your PC with LatencyMon, does the tool report that your PC is ok for audio processing ?

We are doing measurings with LatencyMon in another thread, there you can see how to use the tool and then you have also numbers for comparison: … 38#p178638

@MC: we typed in parallel wink

BR Ramses - UFX III, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1680v4, Win10Pro22H2, Cub13

Re: ADI 2 Pro FS R Black - Relay clicking issue & occasional desync issue?

And what Graphic Card do you use ?
I had some issues with nVidia RTX 2070.
I needed to turn off energy saving on this GPU entirely with a toll called powermizter switcher.
Two results of this
- stability in audio (before I had audio glitches randomly after 15-45 minutes)
- much lower DPC latency (interrupt to process latency) of usually 14-50 microseconds with some peaks around 150

In the forum thread that I linked you above you can see where to get this tool,
which nVIdia driver settings were recommended.
And a reference to a posting from Steinberg forum, where I found this information.

I could validate for me, that the power consumption by this is only a little more, you see screenshots about this as well in the RME thread. Could perhaps be the case that you have a similar situation.
For me it was tricky, as I had no USB3 transport errors and in earlier times with Win7 and an older nVidia GPU  and older nVidia driver everything worked perfect, see here my performance testing with an artificial 400 track DAW project and ~800 VST inserts which I use for stress testing: … cks-de-en/

BR Ramses - UFX III, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1680v4, Win10Pro22H2, Cub13

5 (edited by gaw0319 2021-12-09 05:32:06)

Re: ADI 2 Pro FS R Black - Relay clicking issue & occasional desync issue?

Thanks for the quick replies and excellent information Matthias and Ramses, I appreciate it!

I'm glad to hear the setup is correct. In regards to the relay click, I can confirm that the firmware is up-to-date, although I have not yet tried another power supply. I'm using the included one right now, but I can try another one fairly easily. Do you have a particular recommendation for a brand of power supply I should try, or should any power supply that has the correct voltage/amperage/polarity work well?

The playback issue is a more difficult thing to track down, since it seems to happen randomly, and I'm not yet sure what specific steps I can do to consistently recreate the problem. I'm going to spend some time today running through various projects and sample rates, and when I come across the issue, I'll provide some more information.

Ramses to answer some of your questions:
-Do you use the same drivers and firmware as me ?
I think so - All of the drivers and firmware are on the latest version for the UFX and the ADI-2.

-Options -> Device Mode / DSD -> CC-Mode: "Multichannel"
Previously, I was in Stereo, but now will change it to Multichannel. I will let you know if this seems to have made a difference. In the ADI-2 settings, for "Phones Out 3/4" (which is what I use to feed my analog mastering chain), should I set the Source to something else besides USB 1/2?

-UFX+ is clock master in your setup, do you see in the driver settings: clock source = "internal" ?
-ADI-2 Pro in the "State Overview", do you see in the line AES the status "sync" with proper sample rate ?
-as you also connected AES from ADI-2 to UFX+, do you see in the driver settings input status AES "sync" with proper sample rate ?
All of these things do appear to be correct, yep. I will see if anything changes when I experience the clicking/popping issues, and will check all of these settings.

-Checks in terms of USB compatibility
The ADI-2 is plugged in via the included USB cable, and is plugged into the same set of USB ports that the UFX is plugged into. The motherboard is a Gigabyte Aorus x570 ITX, and running an AMD 3950x. I have not experienced any USB trouble with any of my other devices, but I do know how particular pro audio devices can be. I can definitely try different combinations of ports.
Gigabyte does not make it very clear what the specifics of the USB chipset are though. They're just saying "Integrated in the CPU: 4x USB 3.2 Gen 1 ports. Integrated in the Chipset: 1x USB Type-C Port with 3.2 Gen 2 support, 1x USB 3.2 Gen 2 Type-A port". The UFX and the ADI-2 are both plugged into the USB 3.2 Gen 1 ports, although I will be sure to try out a few others.

-Check for potential load problems
When I notice these click/pop issues, it is usually with projects that are no more than 5-15% CPU load. I've found it extremely difficult to actually top out the 3950x (I think it required something like 700 tracks and 2800 plugins processing audio all at once), so I had figured the issue must be clock-related, since it seems to occur regardless of CPU load or project complexity.

The DPC latency performance of this particular system is thankfully quite good. It sustains at about 30-90us, and peaks are no more than about 175us. Several years back, I spent countless hundreds of hours building and testing various systems and components (I work part-time in IT, so thankfully have easy access to lots of different computer parts), and I managed to find some good recipes for low DPC latency and good low-latency audio performance in that time.

You're right that nVidia is the most problematic one. I tested a 750, a 780ti, a 980, a 1060, a 1080ti, a 2080 Super, a 3060, a 3080, and many different Quadros and mobile nVidia CPUs. Every single one of them had bad DPC latency issues and caused problems with audio work. Disabling Powermizer helped, but the problems seem to be something that is still a bit deeper in the system, and relating to a change in modern chipsets.
Here's an interesting thing I discovered: nVidia GPUs have absolutely no trouble at all on much older chipsets. I have a very old gaming desktop that has a first-generation i7 765, and a laptop that has a 6th generation i7. I swapped the 2080 Super into the first-gen i7 desktop, and DPC latencies were no more than 175us, with peaks no more than 250us. On the laptop with the 6th gen i7, the nVidia card caused DPC latency peaks no higher than ~350us, which is really not too bad.

However, swapping that exact same GPU into an i7-8700k system (even using the same driver version), the DPC latencies sustained around 400-800, and peaked well over 1000us. But, I swapped an AMD Radeon Pro into this same i7-8700k system, and the DPC latencies were significantly lower, sustained near 100 and peaking no more than 200. So, there seems to be some interaction between nVidia hardware and newer CPU chipsets. I don't know what it is, but the problem seems to first appear around the 7th generation Intel CPUs. Around this time, CPU manufacturers were trying to mitigate Spectre and Meltdown vulnerabilities, so this could be part of the reason why the issue started occurring. Either that, or there was some big architectural change between the 6th and 7th gen CPUs that AMD also seemed to follow with in their CPUs.

But yes, long story short, my audio PC uses AMD graphics. I avoid nVidia graphics at all costs when building audio systems for myself or other clients. nVidia GPUs worked fine for audio on older chipsets, but I've found no outright cure for it on modern systems. The Powermizer adjustments do help a lot though!

Re: ADI 2 Pro FS R Black - Relay clicking issue & occasional desync issue?

Here's an update on the relay issue and the clock desync issue. Thankfully, I was able to recreate both issues, and caught both on video. Here's video links demonstrating both issues. The videos are unlisted, so not publicly searchable, but available to view via the direct links:

Relay clicking issue:

Clock desync issue:

With the clock desync issue, I did notice an odd behavior on the ADI-2's built-in screen: The sample rate was flickering back and forth between 88.2k (my default working sample rate) and 48k. I noted this on the video, and with some careful pausing, I was able to see that the video showed flickering between 88k and what I think is 48k. 48k seemed odd to me, since I never use 48k for any projects, but I had realized that this is the sample rate Windows is set at. Could it be that the ADI-2, when this problem occurs, is mixed up between the Windows sample rate via USB, and the sample rate of the UFX+ (which was set at 88k)?

This leads me to another question. Since I am now set in Multichannel mode, should I instead plug in the ADI-2 to the UFX via ADAT as well as AES, and then set the PH Out 3/4 to be fed from the ADAT signal? That way, I can keep the USB of the ADI-2 unplugged, but still have separate access to the PH Out 3/4.

Thanks again for the help here.

Re: ADI 2 Pro FS R Black - Relay clicking issue & occasional desync issue?

Bringing ADI-2 Pro‘s USB out of the equation (disconnect USB), and use the UFX+ as sole USB interface sounds like a good idea.

Check for the really latest firmware, it solved an occasional lost clock issue I had (in a totally different configuration).

The relay clicking + flickering display strongly points to a PSU problem.
Either the plugs not seated correctly, or something brocken.

Check all PSU interconnects for being firmly seated:
• wall outlet,
• mains power strip (if in use),
• mains plug at ADI-2 PSU side,
• ADI-2 DC input - remember the twist-lock at ADI-2 side!

If you have, try a different 12V PSU.


Re: ADI 2 Pro FS R Black - Relay clicking issue & occasional desync issue?

Relay clicking issue: I would remove the unit from that rack so it gets less hot, to see if the effect is still coming back.

Clock desync issue: is nothing like that. This is a clear USB 2 resource issue, which does not bring the error counter up, but causes exactly what you demonstrated. You should have gotten a Windows warning message upon boot of the ADI, but I have seen often enough that no message comes up. So it doesn't matter if you switch the ADI Off/On or simply unplug/plug USB - it will work again.

Solving this requires to check your USB 2 bus state, hub architecture, what is connected where...the ADI should have a USB port that is not shared with other demanding stuff...and that can be something simple like a keyboard wireless dongle...

Matthias Carstens