Topic: [Solved] RME UFX+ not working at all

Hello guys,

I have a very big problem with my UFX+. It worked ok, but now it can not be selected as an output device, and I have tried this on 2 computers, on Windows 10 and 11. The computer sees that it is installed, but I can not select it to be the output device. I have disabled all other output devices, so the UFX+ remains the only one. I din not modify anything to get to this situation, it just happened. I have used this interface for about a year, and every thing was good. All my other devices work without any problem.

Looking forward to hear from you!

Best regards,
Cristi Rada

Ryzen 1800X (8 core) 64GB RAM, Windows 10 20H2, Cubase 11 Pro, RME UFX+, YAMAHA N8, Steinberg UR44

Re: [Solved] RME UFX+ not working at all

> It worked ok, but now it can not be selected as an output device

Sorry, but this is too few information.
As output device for WHAT ? OS or application ? WDM or ASIO ? ....
Which RME driver / version do you have installed ?

Is TotalMix FX running and do you have the driver settings icon in the Windows notification area so that you can open it ?

Just in case you mean usage as default windows sound device...
Did you create WDM devices in driver settings ?
Did you check in Windows Sound that the sound device for the UFX+ is there and set to be the default device for sound ?

Or do you have problems with the DAW and ASIO ?
In that case did you choose the proper ASIO driver  ?
Did you select in the DAW the proper channels from the ASIO driver ?

In fact you deliver nothing in terms of useful information to get an idea what is wrong with your setup.

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro21H2, Cub12Pro

Re: [Solved] RME UFX+ not working at all

ramses wrote:

> It worked ok, but now it can not be selected as an output device

Sorry, but this is too few information.
As output device for WHAT ? OS or application ? WDM or ASIO ? ....
Which RME driver / version do you have installed ?

Is TotalMix FX running and do you have the driver settings icon in the Windows notification area so that you can open it ?

Just in case you mean usage as default windows sound device...
Did you create WDM devices in driver settings ?
Did you check in Windows Sound that the sound device for the UFX+ is there and set to be the default device for sound ?

Or do you have problems with the DAW and ASIO ?
In that case did you choose the proper ASIO driver  ?
Did you select in the DAW the proper channels from the ASIO driver ?

In fact you deliver nothing in terms of useful information to get an idea what is wrong with your setup.

It does not appear in Windows or Cubase.
As I said, I din not change nothing from the day before, when the interface was working properly.
Yes, TotalMix FX appears in Windows.
The driver settings were default.

Ryzen 1800X (8 core) 64GB RAM, Windows 10 20H2, Cubase 11 Pro, RME UFX+, YAMAHA N8, Steinberg UR44

4 (edited by ramses 2022-03-31 13:35:13)

Re: [Solved] RME UFX+ not working at all

How is the UFX+ connect to your PC? Still through USB3 with Sonnet card ?

> Yes, TotalMix FX appears in Windows.
What do you mean by "appear" ? Does TM FX start = This would mean the driver detected the UFX+.

Can you validate this further by:
a) checking whether the HOST LED is still glowing (blue = USB3).
b) whether you can see the UFX+ in device manager
c) whether you can access the MADIface settings dialog

Otherwise the UFX+ looks fine ?
- Host LED working (blue steady light) ?
- Display on ?
- In the UFX+ settings: Options->Interface mode set to Auto ? You could also try USB3 ?
- Options->Hardware/Diagnostics-> Test results shows what number ?

If there are issues please re-check whether the USB3 cable is properly plugged on both sides (UFX+ and PC).
I would also try (all) other USB3 and USB2 ports.
If this doesn't work, try another USB3 cable and try connecting to another computer.

Did perhaps an automatic Windows or driver update take place by Windows Update ? Check update history.
In that case, do you have a good working desaster recovery program (like macrium reflect) that you could restore a Windows Backup from the day where all still worked and without loosing latest "application / project / user data" ?
Depend on the organisation of OS/Programs and user data and whether you split this across two different physical disks ...
Not that you restore the OS and by this user data, if the data still resides on the standard location in the user profile directory tree (c:\users\username\...).

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro21H2, Cub12Pro

Re: [Solved] RME UFX+ not working at all

ramses wrote:

How is the UFX+ connect to your PC? Still through USB3 with Sonnet card ?

> Yes, TotalMix FX appears in Windows.
What do you mean by "appear" ? Does TM FX start = This would mean the driver detected the UFX+.

Can you validate this further by:
a) checking whether the HOST LED is still glowing (blue = USB3).
b) whether you can see the UFX+ in device manager
c) whether you can access the MADIface settings dialog

Otherwise the UFX+ looks fine ?
- Host LED working (blue steady light) ?
- Display on ?
- In the UFX+ settings: Options->Interface mode set to Auto ? You could also try USB3 ?
- Options->Hardware/Diagnostics-> Test results shows what number ?

If there are issues please re-check whether the USB3 cable is properly plugged on both sides (UFX+ and PC).
I would also try (all) other USB3 and USB2 ports.
If this doesn't work, try another USB3 cable and try connecting to another computer.

Did perhaps an automatic Windows or driver update take place by Windows Update ? Check update history.
In that case, do you have a good working desaster recovery program (like macrium reflect) that you could restore a Windows Backup from the day where all still worked and without loosing latest "application / project / user data" ?
Depend on the organisation of OS/Programs and user data and whether you split this across two different physical disks ...
Not that you restore the OS and by this user data, if the data still resides on the standard location in the user profile directory tree (c:\users\username\...).

So I found out which the problem was, and I am sharing with you, maybe someone encounters this situation also.
After the latest Windows update, on the WDM driver all my settings were disabled.
I did not check that initially, because I din not make any changes, so those should have remained the way they were.
Now everything works well again.

Ryzen 1800X (8 core) 64GB RAM, Windows 10 20H2, Cubase 11 Pro, RME UFX+, YAMAHA N8, Steinberg UR44

6 (edited by ramses 2022-03-31 19:41:55)

Re: [Solved] RME UFX+ not working at all

Windows update is known to suck sometimes.
If something does not work, you need to double check settings even if you think that you have done this already.
BTW .. that was one of the 1st things that I asked you in post #2.

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro21H2, Cub12Pro