1 (edited by pietrogirardi 2022-08-23 11:13:40)

Topic: old HDSPe-AIO and windows 11 - latency issues (solved)

Hi there,
I solved a latency issue with a new PC and an HDSPe AIO (discontinued version, not PRO), and I've been asked to share my experience on this forum.
Here’s my brand new PC:

http://speccy.piriform.com/results/hlDc … UJKm3Qv14v

Setting buffer at 128kb (the bare minimum for real time performance on piano - using Keyscape + Cubase Artist 9.5) I experienced clicks and dropouts.

All drivers were up to date - computer was purchased a few week earlier (june 2022), so I did a blank installation of everything.

Disabling all network cards the problem was still there.
Latencymon didn’t show anything particular (“your system appears to be suitable for handling real time audio and other tasks without dropouts").

Even with heavy workloads I don't go past 40% of processor usage, so for sure the i5 12600kf was not the problem.

What follows are all the steps I've taken (a huge THANK YOU to Gearspace user Pictus):

1) No DPC problem, so verify if the RME driver and CUBASE are using the same buffer value.
2) The CPU temperature is OK? Check with https://www.hwinfo.com/files/hwi_726.zip
3) We know the DPC latency is good, but I would try:

Disable Widgets
https://www.elevenforum.com/t/enable-or … s-11.1196/

Disable VBS
https://windowsreport.com/windows-11-vbs-disable/

Disable Hibernate
https://www.elevenforum.com/t/enable-or … s-11.1894/

4) Do the stuff you see at here. and make sure to set PCI Express "Link State Power management = OFF

5) Verify if MSI(Message Signaled-Based Interrupts) is enabled for the RME and Nvidia GPU. WARNING: the old HDSPe AIO does NOT support MSI, so this operation is valid only for the Nvidia GPU and eventually (but not tested myself) for the new HDSPe AIO PRO:
https://forums.guru3d.com/threads/windo … ol.378044/
https://i.imgur.com/Y9VQnb9.png

After taking all the above mentioned steps, I can play Keyscape piano in realtime at the lowest latency setting (32 samples) without clicks or dropouts.

Re: old HDSPe-AIO and windows 11 - latency issues (solved)

Did you have to change the NVDIA to MSI on or was it already on?

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
Babyface pro fs, HDSP9652+ADI-8AE, HDSP9632

Re: old HDSPe-AIO and windows 11 - latency issues (solved)

I had to manually change the Nvidia to MSI.

Re: old HDSPe-AIO and windows 11 - latency issues (solved)

Ah ok thanks, I had no issues but mine, on my laptop, was on msi from the start. Good stuff!

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
Babyface pro fs, HDSP9652+ADI-8AE, HDSP9632