Topic: UFX+ Mic input 10 clipping

Hi there,

Had to make an account on this forum as I have been using my UfX+ to much success over the past year or so, this is my first bit of RME kit and it’s been great so far. However today I noticed that one of the mic inputs in the front of the interface wasn’t working properly as I was recording a stereo instrument and the right channel wasn’t being picked up - this is completely out of the blue as up until this point I have been able to use these inputs without issue.

I have since tried multiple synthesisers, cables, mics and other instruments without any gain staging into this input and within total mix no matter what I set the level to on the channel it’s either completely silent or clipping and distorted. There is a point at around 50% level on the channel strip where this occurs and of course I get the Override LED along with an unpleasant clipping sound. I have tried setting different gain levels, dynamics, eqs etc. I have reset totalmix to a fresh slate and the problem still exists. Running out of ideas as what I can do or if the input is badgered.

What can I do to solve this? I’ve since updated the driver to the latest version, updated totalmix and upgraded the firmware on the interface but with no change. For reference: I am using windows 10, the flash update tool reports that the current usb revision is 54, thunderbolt 111, DSP firmware version 46 and fallback usb revision as 47.

Any help would be greatly appreciated as I’m working on a project and multitracking is essential.


Re: UFX+ Mic input 10 clipping

That sounds like a hardware defect (mic input stage), which needs repair. Contact you local distributor or RME support for service options.

Matthias Carstens