Topic: UFX - Dropping audio, glitching

Hi there,
I have been using a UFX for years in the same setup.
Currently running MacBook air, 15inch , M2, 2023 as studio computer
MAC OS Ventura 13.6.6

UFX - Driver v3.31, Firmware v361

Logic pro v10.8.1 Rosetta

Without changing anything in my studio setup, I noticed my UFX was suddenly switched to 32K sample rate.
I changed back to my usual 44.1k. I was playing a clip from YouTube. The meters in Total Mix are all showing normal with software playback to Output 1-2, but there is no audible audio.

I then opened logic and the same problem.

After re-installing drivers and firmware, it worked on my default snapshot. However when I switched to a different snapshot on Total mix, there was a loud high pitched click and all audio disappeared again. Switching between snapshots creates the same high pitched click but no audio is present.
Intermittently, the default snapshot will work normally but is also prone to cutting out.

When I use logic, it is fine for a little while and then out of nowhere there is a loud click and then constant high distortion which sounds a lot like word clock losing synch.
If I toggle the sample rate on the Fireface settings page, it resets but the same problem occurs again  and again at shorter intervals.

I have experimented with all the different buffer sizes within logic and also the safety offset on the Fireface settings page.
I have also tried installing the new DriverKit 4.10 but was unable to open TotalMix after installing so reverted back to Driver v3.31.

I am totally stumped. If anyone has any ideas I would be most appreciative. I am unable to run my studio at present

Re: UFX - Dropping audio, glitching

In Totalmix is remote Midi off ? I would switch all off.
in the menu options settings Midi : mackie protocol off.

M1-Sonoma, Madiface Pro, Digiface USB, Babyface silver and blue

3 (edited by oli77sch 2024-04-12 08:09:14)

Re: UFX - Dropping audio, glitching

Auto set to 32kHz and no sound and further weird behaviour I only know from cases where the user didn’t allow the 3rd party software (e.g. RME driver) in macOS system settings after driver installation.
But the interface wouldn’t probably work at all if that would be the reason.
Have you properly done the reduced security settings in recovery mode and the whole procedure on your MacBook?
May I ask why you are using Logic on Rosetta?

FF 400 - Babyface pro - Digiface USB - ADI-2 (original)
Mac mini M1 - Macbook pro - iPad Air2


Re: UFX - Dropping audio, glitching

A bit unusual behaviour, but might be the beginning of a dying power supply.

The other known issue is DSP/RAM aging. Does the Reverb and Echo still work correctly?

Matthias Carstens

Re: UFX - Dropping audio, glitching

Thanks for the replies.
waedi, I didn't see an optioning settings Midi : mackie protocol off.
I took a screenshot but can't seem to work out how to upload here

Re: UFX - Dropping audio, glitching

thanks for the reply
Yes I believe I have done everything correctly re permissions and driver updates using reduced security modes.

The reason I am in Rosetta is to be able to use Melodyne (ARA)

Re: UFX - Dropping audio, glitching

Hi MC,
yes reverb and echo all working fine.

I have videos and photos of the issues. Is there an option to upload them on the thread? Sorry if I am missing the obvious

Re: UFX - Dropping audio, glitching

For photos you have to provide an image-address link, you may use this online service :

M1-Sonoma, Madiface Pro, Digiface USB, Babyface silver and blue