Topic: Need Help. RME on SUSE 10.1


recently i switched finaly to linux. (allready thought about it for some time..)
On the Softwareside its not that big of a change, because i use a lot of
Open Source-Multi Plattform tool for years. (Blender, Gimp, Open Office and so on)
The Hardware is what troubles me. First i found out that my Midi Interface is not
supported at all (Midex8) and, to come finaly to the point, i have troubles to
get the HDSP9652 working.

Got the ALSA Drivers v1.0.20 running. But the HDSP is not recogniced by any
The Configuration utility in YAST tell me everytime i open it, that the Card is not
configured. But every attempt ends in the same errormessage.
Apperently the snd-hdsp module can?t be loaded. It is present thoug.

The HDSP Portion of the Hardware-Informations:

35: PCI 507.0: 0401 Multimedia audio controller
  [Created at pci.300]
  UDI: /org/freedesktop/Hal/devices/pci_10ee_3fc5
  Unique ID: mO1u.9XsOjznWXR6
  Parent ID: WL76.vuIf6LvchL4
  SysFS ID: /devices/pci0000:00/0000:00:09.0/0000:05:07.0
  SysFS BusID: 0000:05:07.0
  Hardware Class: sound
  Model: "Xilinx RME Hammerfall DSP"
  Vendor: pci 0x10ee "Xilinx Corporation"
  Device: pci 0x3fc5 "RME Hammerfall DSP"
  Revision: 0x68
  Memory Range: 0xd3000000-0xd300ffff (rw,non-prefetchable)
  Module Alias: "pci:v000010EEd00003FC5sv00000000sd00000000bc04sc01i00"
  Driver Info #0:
    Driver Status: snd_hdsp is not active
    Driver Activation Cmd: "modprobe snd_hdsp"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #24 (PCI bridge)

If i try to activate the Driver via modprobe a mentioned, i get the following errors.

WARNING: Error inserting snd_pcm (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_hdsp (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)

I?m new to Linux so i don?t know how to deal wit it.

I hope someone can point me to the right direction.

Re: Need Help. RME on SUSE 10.1

Hi, when installing ALSA make sure you don't just install drivers, but also everything else in ALSA; libs, utils, tools, and firmware. Though I don't think your card, the 9652, needs firmware.  Most problems I had in the past were with incomplete installs.

If you are concerned about the hardware, you might try a livecd of 64studio.  The RME drivers for the 64studio builds have always worked for me without any modification.  If it works there, you might keep tweaking your 10.1 install to get things straight.

I don't have experience with RME in Suse yet so I can't offer specifics but the lspci output looks fine and I think if the lib portion along with the rest of ALSA is installed right, you should be able to insert the module.  However, following the ALSA instructions is necessary including any kernel compilation options.

Hope this helps!

jonathan adams leonard

Re: Need Help. RME on SUSE 10.1

My Suse installation was just 4 Days old, all i realy did was compiling the Nvidia drivers into the kernel, and messing with the
Settings. (its the first time i?m using any Linux distribution, so there was a lot to discover. Thanks to the Internet i got the
Basics down prety quickly.)
Since there was practicaly no importent data on any hd , i just installed Ubunto Studio and was amazed.
Its way stylisher than Suse.  And extremly easy to install.

The HDSP problem was still there, thoug.

It turned out to be some kind of hardware conflict. Right now i have to disable on Bord Audio in BIOS to get the HDSP working.
Guess i have to experiment with manual irq settings.
However, even if the HDSP is found, only 2 outputs (CH1&2) and no Input is working. I tried to install aditional components of
Jack, but this had the opposite effekt and the card was gone again.
Oh.. and EnergyXt, my prefered Sequencer seem to do nothing when i hit play. Not even the Line moves (the one that show the actual position)

Any ideas how to get the rest of the channels working?

4 (edited by system 2009-07-26 16:46:23)

Re: Need Help. RME on SUSE 10.1

If you are in the mood to experiment further I would strongly suggest installing 64studio.  I have worked with Ubuntu Studio and while you can get things working following the various sets of instructions and maze of incomplete forum posts it will take you longer than 64studio.  BTW 64studio is now using an Ubuntu base, but with their kernel and mods is a great starting place.

If your soundcard was conflicting with HDSP then you may have to either disable it in the bios as you discovered, or set the card index in /etc/modprobe.d/alsa-base  whatever gets set to card index 0 will be the default, and you can set the card's indices so they don't switch on you later.  For example maybe sometimes jack thinks HDSP is device hw:0 and other times your you prevent that and define for the system what the order is.

If one of your audio apps like EnergyXT won't play it is because the audio driver is not working correctly.  Ardour will do the same thing.

To get more channels using jack, use a setup in qjackctl that specifies number of inputs and outputs as the default settings are conservative.  Once the jack server is running with qjackctl using your settings, you can run other apps....depending on how they work you may have to manually connect their outs to jack using the connect panel in qjackctl....just drag them over.

Ubuntu Studio should have hdspmixer - this is totalmix for your card.  Some people have found it is necessary to run hdspmixer at least once after booting to make sure everything is initialized properly.

jonathan adams leonard

Re: Need Help. RME on SUSE 10.1

It?s finaly working!
First i installed Ubuntu Studio 64. The first result was realy demotivating. Now the Alsa drivers didn?t load at all (terminated with an Errormessege about snd-hdsp).
After a few hours of fighting with the software, i figured it has to be hardware-related. It was all a matter of switching pci-card-positions.
With the HDSP in the lowest slot, it worked out of the box, as described by others.
The downside is that Energy XT seem to only run on 32 bit systems. I cant find a 64 bit version of it.
Dose anyone of you know, by chance, if there exists a 64 bit version of energy-xt?
Another problem is the midi setup. Since the Midex8 isn?t supported by Linux at all (because Steinberg made shure to prevent this) i have to change my midi interface. Probably to a Midisport or something. Right now i misuse my Microcontrol to interface with the computer via usb, with worked at the first try without any Problem whatsoever. I connected the midi out of the Microcontrol with the Midex and disconected the usb from the midex (powering it with a power supply). Its just a workaround to be able to play at least one synth at a time.

Hopefully i find the 64 bit version of Ext, and buy a new midi interface with linux support, and i?m all set.
Oh.... and for Graphic-Application Ubuntu Studio 64 is just stunning. Blender runns about 2 to 3 times faster than on XP.