Topic: New FirefaceUC USB loading wrong firmware

I have searched the forum for an answer for this before posting.
However, I could not find and exact solution.

I have purchased a new FirefaceUC USB yesterday and ran home for trying it.
I was a long time RME user before I started using Pro Tools.
Now, I am back since I am using Logic mostly.
I had great experience with the first time installation before withe the first generation RME Multiface.
I had the mobile and the PCI card, exchanging computers at the studio or at the gig, depending on what I needed.
Worked every time so I was a happy user.
I wanted to go on with RME again.

However, I had a different experience yesterday.
It took me 3 hours to solve the problem, but it was solved by itself.
So I am not sure what the solution is.

I have a MacBook Pro with the following specs;

  Model Name:    MacBook Pro
  Model Identifier:    MacBookPro5,1
  Processor Name:    Intel Core 2 Duo
  Processor Speed:    2.4 GHz
  Number Of Processors:    1
  Total Number Of Cores:    2
  L2 Cache:    3 MB
  Memory:    4 GB
  Bus Speed:    1.07 GHz
  Boot ROM Version:    MBP51.007E.B05
  SMC Version (system):    1.41f2

I have installed the drivers, then connected the cables ad turned on the unit.
OS X did not recognize it.
Then, I found out how to check which firmware is loaded and realized it was loading the PC firmware.
I have 500GB hard drive partitioned 400GB for OS X and 100GB for windows.
I do NOT have Parrallels Desktop installed.
I am using bootcamp to boot on the OS for my needs.
For C# development, I use windows and for music I use OS X.
I have Logic 9.1 installed.
I also have PT LE installed but I am going to remove that after I sell my Digi002.
I also have Apogee One drivers installed since I use it from time to time.
That is all there is to know about my system.

Since I had problems with OS X, I booted to Windows 7 hoping to load the newest firmware from that OS.
I thought that might fix the problem.
However, like a joke, when I did that, Fireface loaded the Apple firmware and was nto recognisable in that OS either.
After 3 hours of struggle, I gave up and booted in to OS X again.
Luckily, Apple firmware was loaded this time.
From then on, everything was problem free.
However, this scares me a little since i did not do anything to correct the problem.
It was done by itself.

I have the latest firmware and the drivers installed now.
Wil this problem come back?
Can I trust this unit at field recordings now?
?f it does come back, can I choose which firmware to load manually?

Any ideas?


Re: New FirefaceUC USB loading wrong firmware

However, like a joke, when I did that, Fireface loaded the Apple firmware and was nto recognisable in that OS either.

You can change the OS firmware anytime on the disconnected UC with a double click on the encoder button on the front. Did it not work?

From the manual:
Check the correct firmware version by a double click on the rotary encoder button. The display PC means Windows, the display AP means Mac. The double click automatically switches between both versions. Note: a change of state is only possible when the unit is not connected to the computer.

best regards

Re: New FirefaceUC USB loading wrong firmware

Thanks for the reply.
Yes, I had read that in the manual.
And, yes it works correctly.

It's just that the speed of the double-click takes some getting used to.
I now know which speed of the double click fireface understands.

Thanks a lot.