Topic: FF400 Not Communicating with Computers

I have an FF400 that's a few years old. I haven't used it regularly for the past few months, but the couple of times I've used it, I had to reinstall the driver to get it to communicate with my computer (that is, to get the WC light green as opposed to a red "Host" light... or no LED at all lighting up).

So, today I have turned on my system, and no LEDs come on unless I unplug the Fireface, at which point the red "Host" light comes on. I tried to reinstall the driver, but I can't seem to be able to. In fact, I can't even open the RME driver dialog, nor the mixer. So I uninstalled them and ran a registry cleaner. Didn't help. I can't get the RME driver, mixer, or flash update to even open on the computer.

So then I switched to another computer I don't use as often, but have used quite a bit with the FF400 in the past. It already has the drivers and such installed. Same thing happened: the FF400 won't communicate, and even with the FF400 unplugged from the computer, I can't even open the RME driver dialog (by which I mean the box where you select sample rates, etc...).

I have used different firewire cables. I'm not sure, but it seems that a couple of months ago when I used it, it only worked out of one of the two firewire ports in back of the Fireface. As I say, I'm not sure about that, but have a vague memory of it.

Ok, so is my FF400 fried? Any suggestions?