Topic: babyface mic inputs

I just got a new babyface and love the way it sounds. I just made my first attempt at recording (using a Shure VP-88 stereo mic) and was confronted with what seems to be some serious ground problems.

First off, no sound from the mic gets into the bf (with phantom power). What does occur (with or without phantom) is a loud buzz whenever I touch the mic that gets even louder when I touch both the mic and the bf. If I hold on to the bf for too long I start feeling an electrical charge. Surely this can't be good. Yet another interesting thing is the buzz gets considerably quieter when I unplug my MacBook (OS 10.5.8) power. But still no audio from the mic.

I did try using the same mic with another audio interface and it works fine, so it has to be the bf.

Am I missing something really basic or do I indeed have a faulty unit (or faulty breakout cable set perhaps)?


black macbook (late 2008) 2.4 GHz, OS 10.5.8; TotalMix 0.924

Re: babyface mic inputs

I have somewhat of a similar story:


I am having some trouble powering a Røde NT1 phantompowered microphone (or should I say, problems recording through it).
I am on a Macbook Pro, early 2008 model, Intel Core duo 2, 2 GB RAM, Snow Leopard OS X.
My main DAW is Pro Tools 9.

Essentially the problem is that it doesnt seem that Babyface is giving sufficient power to my microphone. The unit works fine otherwise, instrument in works fine, playback works fine (all though switching between total FX and Pro Tools, seems to lag the latter a bit in its operation). Latest drivers are installed of course.
I get a signal, but the signal is very weak, having me to raise the gain a lot in order to hear anything, and of course this raises the noise floor too much, making it unusable for recording. The microphone works fine on my Mbox 2 pro, and the cable is brand new.

Wiggeling the breakoutcable seems to make a bit of a difference (signal sometimes coming in), but with randomness it seem.

Touching the metal of the microphone (the casing/capsule) generates electric charge.
Removing the powersupply form the macbook does not make a difference, but when i did remove it (for testing if this would help), i could feel the electric charge of the power adapter on my right hand (holding the mic in my left). Do you guys have any idea what is causing this? Sounds to me like a grounding/earth issue. But where lies the error?
I'm getting the same error on two different Babyfaces (received a new one from the vendor and had the chance to A/B the two units). I am waiting for my third unit now, hopefully this one works as anticipated.


3 (edited by psychedelia 2011-03-01 05:14:00)

Re: babyface mic inputs

RME - an answer please?

Re: babyface mic inputs

Just heard back from rme support:

"This is not a known BF issue. There have been, however, similar issues with the macbook, it seems. … D=12354402   "

Seems this could possibly be unique to 2008 macbooks.

Anyone out there with a non-2008 macbook having this same issue?

Re: babyface mic inputs

I actually got a new Babyface in the post today, and voila, it is working fine. So it is definitely a Babyface issue - could have been I had two bad units, but that just doesn't seem very likely. Anyways, finally a happy Babyface user here, however, disappointed that RME didn't get back to us here on the forum (and neither responded to my email).

Re: babyface mic inputs

Yes, a little disappointed with their handling of this. But good to know it was the individual unit for you. I'll try replacing mine and see what happens.

Re: babyface mic inputs

Hope it turns out OK man - hopefully the first replacement will work for you!

Re: babyface mic inputs

It was a faulty unit. The replacement works fine!