1 (edited by Jperkins 2021-06-29 20:45:41)

Topic: AIO Pro Disappearing

I recently picked up a new AIO Pro card for my Mac Pro to use for listening to Qobuz and other sounds on my Mac because I've had the RME AES card for years and love it.

Overall it's working well but twice now, the AIO card has disappeared from being visible anywhere on the Mac (Audio MIDI Settings, any audio apps, etc.). It's just like it's not even connected.

The RME AES card is still there, and so is everything else.

Restarting and Shutting down the Mac Pro doesn't solve it. The only thing that has solved it is shutting down the Mac Pro and disconnecting the power cable for a few seconds.

Then, when I start up the Mac again, all is well...until next time.

Is this something that can be fixed with an update? Or am I trying to run too many things on the Mac Pro PCIe buss?

Here is a system report:
https://www.dropbox.com/s/qws404fiyeywr … o.spx?dl=0

And here is a screen shot of some more info:
https://www.dropbox.com/s/qws404fiyeywr … o.spx?dl=0

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

2

Re: AIO Pro Disappearing

SPX?

What firmware is in use? We had a lot of updates since the card was released, currently on 21.

Regards
Matthias Carstens
RME

Re: AIO Pro Disappearing

MC wrote:

SPX?

What firmware is in use? We had a lot of updates since the card was released, currently on 21.

SPX is some kind of report for the Mac I believe.

I am using Rev 21 which I installed the day it arrived a few weeks ago.

I also have an RME AES (and the daughter card) in the same Mac if that matters.

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

Re: AIO Pro Disappearing

And so far it has only happened twice in roughly 3 weeks, and at least I know how to solve it. I was just reporting it here to see if it has happened to anybody else.

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

Re: AIO Pro Disappearing

I just had another case where the AIO was visible and selectable but it was not outputting anything via SPDIF. I powered down the Mac Pro, disconnected the power cable (which produces a faint click telling me it really powers it all down), and the restarting the computer and the sound was back.

My RME AES worked the entire time so this seems tied to the AIO card somehow.

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

6 (edited by Jperkins 2021-07-05 15:17:12)

Re: AIO Pro Disappearing

This is happening more often. It seems to happen after I let the computer sleep or whatever happens when I walk away for a few hours.

I noticed that when the issue came back, this is what the HDSPe app said:
https://www.dropbox.com/s/z9lgmjvyd9ts7 … M.png?dl=0

After shutting down the computer and disconnecting power and rebooting, here is what it says:
https://www.dropbox.com/s/bcqu6qrn2mfaz … M.png?dl=0

Notice that when I have the issue it says Firmware 0

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

Re: AIO Pro Disappearing

Twice this week I've had the AIO card stop transmitting audio, and when I check the app is says Rev. 0.

Is there anything that can be done to prevent this from happening? The only fix on my end is to shut down the Mac Pro, and then disconnect the power cable to fully remove power, and the restart.

Here is what the app shows:
https://www.dropbox.com/s/m1acsyfsqfsx6 … M.png?dl=0

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

8

Re: AIO Pro Disappearing

We are currently working on that subject. I'll keep you updated as soon as news arrive.

Regards
Matthias Carstens
RME

Re: AIO Pro Disappearing

MC wrote:

We are currently working on that subject. I'll keep you updated as soon as news arrive.

Thanks! The AES card that I've had for a few years now is always perfect. It's the newer AIO Pro that seems to keep doing this now and then.

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

10

Re: AIO Pro Disappearing

Intermediate question - are you still on firmware 21 as shown in the screenshot of post 6? Version 22 has been released on 09/22 and includes an improved boot behaviour. Worth a try!

Regards
Matthias Carstens
RME

Re: AIO Pro Disappearing

MC wrote:

Intermediate question - are you still on firmware 21 as shown in the screenshot of post 6? Version 22 has been released on 09/22 and includes an improved boot behaviour. Worth a try!

I am. I didn't notice the update but I'll look for it and do the update now.

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

12 (edited by Jperkins 2021-10-21 15:28:15)

Re: AIO Pro Disappearing

Actually, I'm on MacOS 11 so the way I see it, the last update I can do is from 2020-11-27.

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

Re: AIO Pro Disappearing

I just did the Flash update and my AIO is on firmware 22. I'll report back if the issue persists.

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

14

Re: AIO Pro Disappearing

I'm confused. What makes you think the latest FUT won't work under macOS 11?

Regards
Matthias Carstens
RME

Re: AIO Pro Disappearing

MC wrote:

I'm confused. What makes you think the latest FUT won't work under macOS 11?

The way the updates are organized confuses me.

If I check the Mac OS X section, it makes it seem like the last update for MacOS 11 was on 2020-11-27
https://www.dropbox.com/s/e7tmgc9lanfel … M.png?dl=0

But if I check the Flash Update section, it just says "Mac OS X" and doesn't really imply if it would work for MacOS 11
https://www.dropbox.com/s/e7tmgc9lanfel … M.png?dl=0

But since it was the only Mac option in that section, I tried it and ti worked.

Are Flash Updates for the firmware and the Mac OS X Section updates for the mixer software?

It's honestly a little confusing as to what is what but I do check that page often to see if any updates are available.

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

16

Re: AIO Pro Disappearing

Jperkins wrote:
MC wrote:

I'm confused. What makes you think the latest FUT won't work under macOS 11?

The way the updates are organized confuses me.

If I check the Mac OS X section, it makes it seem like the last update for MacOS 11 was on 2020-11-27
https://www.dropbox.com/s/e7tmgc9lanfel … M.png?dl=0

This is about firmware, not the driver. And the firmware is right on top in your pic.

But I fear v22 will not fix your AIO Pro issue, as the change I had in mind was already part of v21. Either way, please post your result.

Regards
Matthias Carstens
RME

Re: AIO Pro Disappearing

I went to the HDSPe settings app to show you a screen shot of my upgrade to 22 for the AIO and sure enough, it's set to 0 again.

I'll have to shut down the Mac and disconnect it from power for a moment to get it back working again. Hopefully this can be addressed in 23!
https://www.dropbox.com/s/8v34lq0tnozwq … M.png?dl=0

http://www.mysteryroommastering.com/
http://www.justincarlperkins.com/

18

Re: AIO Pro Disappearing

Thanks for confirming.

Regards
Matthias Carstens
RME