1 (edited by rip 2018-04-10 14:33:12)

Topic: Another 'Mac Allow doesn't work' story, and solution

i am setting up my Fireface UFX with a brand new iMac purchased yesterday (21 inch quad i5) OS version 10.13.4

my first mistake was installing the firewire drivers instead of the usb drivers.  once I realized that i had installed the wrong drivers i installed the usb drivers.

the symptoms are:

  • Fireface USB settings app sees the devices serial number and can change clock source but cannot change the sample rate (when I change clock source in app I se change reflected on device, but not sample rate).  If I turn off the device it and its firmware / driver info go away from the UI as expected. so the computer sees and can talk to the device

  • Totalmix doesnt see the device at all (nothing appears in New Totalmix Window device selection list)

  • Fireface Flash Tool sees the devices serial number but cannot flash the device, when I click Update nothing happens. also, under the Current Revision column, the flash tool sees the correct version for USB but reports 0 for the other firmwares.  When i test on different mac the correct values are shown

  • Mac Audio MIDI setup does not see the device at all

Update: I have tried uninstalling all RME software and reinstalling drivers per this https://www.forum.rme-audio.de/viewtopic.php?id=9233 but to no avail.  Note I could not find all of the plists listed.  Maybe the post needs updating?

Update: have tested the device on my wifes Macbook Air (using 2.x drivers) and the device works great so we can rule out hardware errors, the problem is entirely the config of my Mac.  using her Mac I have flashed the device to the latest firmware.

2 (edited by rip 2018-04-10 16:10:43)

Re: Another 'Mac Allow doesn't work' story, and solution

Fascinating conclusion to my story:

I tracked the problem down to the changes in High Sierra security regarding 3rd party kexts.

I followed the instructions listed on the RME web site, in the Mac Security control panel, when I tried to click Allow, nothing happened


then I found this


I have just figured out the answer to this question. On a different post, I read this comment from someone "Because of security reasons pressing the Allow button won’t take effect if you are connecting to the machine via Remote Desktop, or if the mouse/trackpad is emulated by a 3rd party application (MagicPrefs, BetterTouchTool, Synergy, etc.)"

Even though I dont have a third party emulator of the same kind in the examples, I realized maybe TeamViewer, and other similar apps might do the same thing - to allow mouse/trackpad input while remote controlling mac. So I started closing apps one after the other and none seemed to have helped. Finally, I disconnected the ethernet cable, and turned off wifi. I was then able to click 'Allow'.

Chrome was preventing this button from being pressed.  When I closed Chrome, the Allow button started working.  I suspect Google is capturing mouseclicks.

Hope this helps someone in the future.


Re: Another 'Mac Allow doesn't work' story, and solution

Nice information, thanks. I renamed this thread to make it easier to find and reflect its content better.

Matthias Carstens