Topic: Other Software Update Kills RME Drivers

Twice now, I have updated some software that wiped out RME permissions on MacOS that prevented it from opening.

I had to go into the Terminal and do some crazy stuff to eventually get it back.

I know about the thread that details how to do this but the info was not 100% correct which meant it cost me a few hours time, again.

I know the thread says that it's an Apple fix but how come this doesn't seem to happen with any other software bedsides the RME Total Mix and HDPSe apps?

I use a fair amount of software that requires me to "Allow" it in the Security & Privacy area and this has never happened with any other software, just RME. Twice.

I hope it can be addressed on the RME side so it doesn't keep happening.

2 (edited by Jperkins 2022-03-31 14:37:29)

Re: Other Software Update Kills RME Drivers

Once again, updating Universal Audio plugins software wipes out my RME apps and I have to f*ck around again for an hour at least to reset it trying to guess what I need to type into the Terminal in Safe Mode to reset the permissions.

Can RME please fix this ASAP? Ain't nobody got time for this.

Re: Other Software Update Kills RME Drivers

Once again, today's Universal Audio update killed my RME drivers and I had to boot in recovery mode and do some work in the Terminal, restart the Mac, reset permissions for a number of things and then restart again and then check on everything.

It would be VERY nice if I didn't have to do this every time there is a UAD update.

Since the other thread is closed and the steps to really fix it are spread throughout multiple posts and isn't super clear, here is a screen shot of what I typed into the Terminal and what it told me. Luckily I guessed on the first try this time.

Since I don't think you can take a screen shot in Recovery Mode, here's a phone photo for reference:

https://www.dropbox.com/s/7t5vjb9v50yyq … .jpeg?dl=0

Re: Other Software Update Kills RME Drivers

And despite the Terminal telling me it was a success and then re-permitting RME and others in the System Prefs, RME apps would still not launch so I did all that again and this time put an underscore in Macintosh_HD and now it appears to really be working again.

RME apps are launched.

5 (edited by Jperkins 2022-07-23 14:44:42)

Re: Other Software Update Kills RME Drivers

This happened AGAIN last night after updating an app called SoftRAID which I have to use for my OWC SSD hard drives even though I don't use them in a RAID configuration.

After updating this app, my RME apps did not launch, just like what's been happening when I update the UAD software.

I was one last attempt away from upgrading to Monterey in a desperate attempt to get my RME drivers/apps working again.

For the love of got PLEASE fix this. It only happens to my RME apps/drivers. This time it took over an hour of various attempts to run the terminal command and re approve permissions to things in various order so that everything finally worked again.