Topic: Fireface 800 and Ventura MacOS

Hey,
searched any clear information, but still not sure do I have to start planning to figure out replacement for FF800? Now it runs great on MBP M1 with 2 dongles into Thunderbolt 3 port.
Will drivers be updated or current ones also will work? Do not want to try beta of Ventura but maybe someone did?

2 (edited by Apfel 2022-09-18 14:38:15)

Re: Fireface 800 and Ventura MacOS

Hi,

to my knowledge Apple will discontinue any Firewire support with Ventura. RME will be unable to do something about it and there won't be new drivers (as they told me). So one will have to stick with Monterey.

I have a Fireface 800 working perfectly on a M1 iMac with Monterey. Because that machine's purpose is only for doing that alone so I will have no need for an upgrade to Ventura for other reasons.

Michael

Re: Fireface 800 and Ventura MacOS

Same here. Agree then. Browsing or mail will work anyways:)
And seems have to move to usb/TB eventually.

Re: Fireface 800 and Ventura MacOS

atrodysimgerai wrote:

And seems have to move to usb/TB eventually.

I won't spend thousands of Euros for a new USB-Interface of the same quality as the Fireface as long as that one works. It is 17 years old. One never knows …

Re: Fireface 800 and Ventura MacOS

This device has been such an amazing and perfect workhorse, and it's a damn shame Apple are killing off connectivity for it (most hardcore FF800 heads have a TB3 ext PCI chassis to use TI-based firewire cards to keep on truckin' ).

Since this may finally be the "end of the road" on MacOS capabilities to allow FF800 to go another decade --- I wonder if we could perhaps rally RME to offer a one-time discount to existing FF8000 owners to make the move to their newer interfaces?

6 (edited by TX-Jdub 2022-10-27 05:52:03)

Re: Fireface 800 and Ventura MacOS

Thread update: FireWire 800 is supported, and FireFace 800 works with Ventura at release time Oct 25 2022!

Re: Fireface 800 and Ventura MacOS

Good news for anyone who has an RME Fireface 800 interface.

I can confirm that it is working without the slightest problem with MacOS Ventura.

I use the apple USB-C->thunderbolt cable -> Firewire -> Thunderbolt -> Firewire 800 cable snake combination and it is working absolutely brilliantly.

I am using Ableton 11 and it found the Fireface 800 without a hitch. All plugins seem to work fine so far and I am very relieved as the rumours made me think I would have to buy a new sound interface!

So feel free to upgrade if you wish. :-)

Re: Fireface 800 and Ventura MacOS

Great!

I think I will wait for Ventura 13.1 anyway. But good to know that Firewire support is still there in Ventura.

Re: Fireface 800 and Ventura MacOS

dmb wrote:

Good news for anyone who has an RME Fireface 800 interface.

Great news... Thanks mate... I have the same connection like you... Happy to hear that... :))

Re: Fireface 800 and Ventura MacOS

thats great!
tho went already another direction with EVO16+ferrofish adat, and FF800 now is as a standalone mixer, as never enough analog inputs:)
only one free channel left:)
https://ibb.co/7SVh20j

Re: Fireface 800 and Ventura MacOS

dmb wrote:

Good news for anyone who has an RME Fireface 800 interface.

I can confirm that it is working without the slightest problem with MacOS Ventura.

I use the apple USB-C->thunderbolt cable -> Firewire -> Thunderbolt -> Firewire 800 cable snake combination and it is working absolutely brilliantly.

I am using Ableton 11 and it found the Fireface 800 without a hitch. All plugins seem to work fine so far and I am very relieved as the rumours made me think I would have to buy a new sound interface!

So feel free to upgrade if you wish. :-)


Hi man. Can you please contact me on private? I have MacBook Pro 2022 M2 with ventura and Fireface 800.
Had download the last driver and bought all cables but when I connect the apps doesent open like total mix etc. can you please help me ?

Re: Fireface 800 and Ventura MacOS

dmb wrote:

Good news for anyone who has an RME Fireface 800 interface.

I can confirm that it is working without the slightest problem with MacOS Ventura.

I use the apple USB-C->thunderbolt cable -> Firewire -> Thunderbolt -> Firewire 800 cable snake combination and it is working absolutely brilliantly.

I am using Ableton 11 and it found the Fireface 800 without a hitch. All plugins seem to work fine so far and I am very relieved as the rumours made me think I would have to buy a new sound interface!

So feel free to upgrade if you wish. :-)

Also here, Fireface 400 (which uses the same driver as the 800) works absolutely well on Mac mini M1 2020 with Ventura 13.1 on it (same double-adapter-snake as Gianste). Only thing I had once is a not recognized interface when it's plugged in the already running Mac. Because my Fireface doesn't work with bus power anyway, I simply have to power up it first before starting the Mac.

FF 400 - Babyface pro - Digiface USB - ADI-2 (original)
Mac mini M1 - Macbook pro - iPad Air2

Re: Fireface 800 and Ventura MacOS

Fireface 800 seems to work flawlessly with Ventura 13.1 on iMac i7. 

Connecting the Fireface by chaining a Firewire 800 -> Thunderbolt adapter into a Thunderbolt -> USB-C adapter. 

After upgrading the Mac OS to Ventura, powered up the Fireface 800 which immediately launched the RME TotalMix and RME Fireface Setting apps in the background.  All of the inputs show up in Logic and so far everything seems to work just as before the Ventura upgrade.

Thanks guys for posting your findings and thanks RME for building the brilliant Fireface 800! 

Cheers all!

Re: Fireface 800 and Ventura MacOS

I have a FF 400 and recently bought (as in last week) a M1 Pro MBP. I went to my rehearsal studio where my FF400 is. Did the whole thing with allowing 3P kernels, and put on the latest RME drivers.

Plugged in the FF400 with the Apple FW800-->TB2 then TB2-->TB3 adapters.

The computer recognizes the FF400 and the ADAT ins... but isn't taking any signal. However, it does take signal from the FF400's SPDIF inputs (I plug my Line 6 Helix in via SPDIF for tracking in the room).

I'm not sure if I have an issue with my Audio/Midi settings or what, but this is super frustrating. We had a jam last night that I really wish I could have recorded.

I'd appreciate any guidance on this front.

Re: Fireface 800 and Ventura MacOS

dirtyfunkg wrote:

I have a FF 400 and recently bought (as in last week) a M1 Pro MBP. I went to my rehearsal studio where my FF400 is. Did the whole thing with allowing 3P kernels, and put on the latest RME drivers.

Plugged in the FF400 with the Apple FW800-->TB2 then TB2-->TB3 adapters.

The computer recognizes the FF400 and the ADAT ins... but isn't taking any signal. However, it does take signal from the FF400's SPDIF inputs (I plug my Line 6 Helix in via SPDIF for tracking in the room).

I'm not sure if I have an issue with my Audio/Midi settings or what, but this is super frustrating. We had a jam last night that I really wish I could have recorded.

I'd appreciate any guidance on this front.

Hi! Welcome to the forum.
At least it seems the installation process went well so far. Anyway strange behaviour…
Do I get it right, the SPDIF input is the only working one? No signal neither from the analog 1-8 inputs nor from ADAT 1-8?
On your previous computer there was all ok? What OS was on there?
The firmware version is a point to check for sure.
Then also the settings in Mac audio/midi app, are there all channels active?
To go further some screenshots would be very helpful (TotalMix window, Fireface settings, audio/midi setup).

FF 400 - Babyface pro - Digiface USB - ADI-2 (original)
Mac mini M1 - Macbook pro - iPad Air2