1 (edited by zr0sum 2023-04-11 15:52:57)

Topic: "AES NON-AUDIO": Fireface UFX+ & (via AES/EBU) ADI-2 PRO FS R BE


I would be very greatful for some advice on an error/problem I am running into.
See "Problem description" for details on error.

Devices & connection:

- Fireface UFX+ (Firmware v54, 2023-03-31)
- ADI-2 PRO DAC FS R Black Edition (Firmware v117, 2023-03-31)
- Above devices connected together via AES/EBU

Use case:
- UFX+ is used for recording
- Monitoring set up is connected via the 1 analog outputs of ADI-2

Tested with two machines:

M1 Mac:
- UFX+ (only) connected via USB 3
- Latest USB driver v4.07 (2023-03-18)
- macOS Ventura 13.2.1
- M1 Max, 64GB RAM

Windows 11 PC:
- UFX+ (only) connected via USB 3
- Latest USB driver v0.9812 (2023-03-17)
- Windows 11 Version 10.0.22621 Build 22621
- Fresh install, nothing on the machine apart from RME & system drivers
- CPU: AMD Ryzen 9 3900X 12-Core Processor, 3801 Mhz, 12 Core(s), 24 Logical Processor(s)
- Mem: 32GB
- Mobo: BaseBoard Product    MEG X570 UNIFY (MS-7C35)

Problem description:

macOS (OK):

I encounter no issues with the above system in macOS. Everything functions perfectly.
TotalMix FX, along with output through the ADI-2 and output via Analog 1/2.

Windows 11 (AES error):

If I switch to Windows without modifying device settings (simply plugging in the cable).
At first when installing the drivers and rebooting things work.

Following that, if I enter the MADIface Series Settings for the UFX+ and modify only the sample rate:
- ADI-2 displays an error "Non-audio signal at AES input", and
- ADI-2State Overview page shows "AES NON-AUDIO" (red text)
- Both devices show they are synced
- The bitrate on the ADI-2 State Overview changes to show 16
- UFX+ and Total Mix FX+ function normally, but there's no audio coming from the ADI-2 via AES

After this, no matter what I do (changing the sample rate back or trying any other settings), I cannot restore functionality.
If I re-install the driver, turn off both devices and restart, things work again but whenever the sample rate changes things break and I have to repeat the process.

WDM devices setup (mode: stereo):
- Analog (1+2), used as an playback device in Windows
- Analog (9+10), used as a (microphone) input device in Windows

Things I have checked/tried:

- Every screen (SETUP/REV, CHAN/MIX) on UFX+ comparing between working macOS and non-working Windows state: no differences
- Can't find any differences on ADI-2 in working vs. non-working state
- Tried starting fresh with Total Mix FX multiple times and no luck
- Resetting both devices to default state

I am sure it's probably a simple problem resulting from my misunderstanding of something.

Since this starting to drive me a little crazy, any help would be appreciated! smile
Been trying to fix this for days now.

P.S. I noticed someone had the same issue with a pre-release (v0.9815) driver in this thread: https://forum.rme-audio.de/viewtopic.ph … 01#p200501

Rolled back to the previous driver 0.9808 because I got a message on my ADI-2 Pro FS R (which is connected via AES to my UFX+) saying 'NON-AUDIO AES'.
Having rolled back everything is working as before.

But this driver is not pre-release. If it's not user error on my part, could a bug in current (v0.9812) exist too? Perhaps I should roll back. Unsure if that is safe though. Where can I find v0.9808 to test it?

Thank you!

Update 1:
- Found v0.9808 here, https://rme-audio.de/downloads/driver_m … _09808.zip
- Testing now...

Update 2:
- Not experiencing the issue on the v0.9808 driver.
- Will update this post if it happens again.

Update 3:
- Still no trouble (4 hrs of use after), going to call this solved by downgrading to Windows driver version v0.9808
- Hopefully this can be fixed in the upcoming version


Re: "AES NON-AUDIO": Fireface UFX+ & (via AES/EBU) ADI-2 PRO FS R BE

https://forum.rme-audio.de/viewtopic.ph … 01#p200501

Matthias Carstens

Re: "AES NON-AUDIO": Fireface UFX+ & (via AES/EBU) ADI-2 PRO FS R BE



Re: "AES NON-AUDIO": Fireface UFX+ & (via AES/EBU) ADI-2 PRO FS R BE

Version 0.9816 has been released with a fix for the UFX+ AES output.

Matthias Carstens