Topic: Multiface II Feedback loop

I have several speakers set on the analog outputs of my Multiface and I use a measurement microphone for measurments - If I connect the Mic to analog input 0 it seems to work and I can record my measurements . If I connect the mic to input 4 and leave input 0 open the mic feeds back directly with the speaker on output 0 as soon as I turn the amp and microphone on- This damaged my speaker and I didn't want to do it again,.  If I do not have anything connected to output 0 then I don't have a problem with the other channels

Why is this happening? Does the analog input default to output 0 unless the 0 input is used. I seem to have solved the problem but I wanted to be sure I understood why so I don't blow up more speakers.


Re: Multiface II Feedback loop

Scratch my last post - Maybe this belongs on the linux forum - I had  this amixer command:  amixer -c 0 cset numid=5 4,0,32768 - So 0 would be ok and probably wouldn't record either

So it appears that whatever input I connect the mic to it outputs to 0 


Re: Multiface II Feedback loop

I have investigated my feedback problem further and when my microphone is connected to either input 0 or input 4 it sends output to output 0 causing a loop. All other channels are fine. I am thinking:

a) amixer set up wrong (see below)
b) some other setting I don't know about
c) a hardware problem

killall klogd
killall syslogd
killall inetd
killall tee
killall tail
#IEC958 Output also on ADAT1 = off
amixer -c 0 cset numid=7 0
#IEC958 Professional Bit = off
amixer -c 0 cset numid=8 0
#IEC958 Emphasis Bi = off
amixer -c 0 cset numid=9 0
#IEC958 Non-audio Bit = off
amixer -c 0 cset numid=10 0

#Sample Clock Source = 48000
amixer -c 0 cset numid=11 3
#Preferred Sync Reference = coax
amixer -c 0 cset numid=14 1

#Passthru = off
amixer -c 0 cset numid=21 0
#Line Out = off
amixer -c 0 cset numid=22 0
#Analog Extension Board = off
amixer -c 0 cset numid=26 0

#Channel Connections
#clear all direct physical connections for safety
for ichannel in $(seq 0 1 25)
do amixer -c 0 cset numid=5 $ichannel,$ichannel,0

#playback connections for  channels
amixer -c 0 cset numid=5 26,0,32768
amixer -c 0 cset numid=5 27,1,32768
amixer -c 0 cset numid=5 28,2,32768
amixer -c 0 cset numid=5 29,3,32768
amixer -c 0 cset numid=5 30,4,32768
amixer -c 0 cset numid=5 31,5,32768
amixer -c 0 cset numid=5 32,6,32768
amixer -c 0 cset numid=5 33,7,32768
amixer -c 0 cset numid=5 0,0,32768
amixer -c 0 cset numid=5 1,0,32768
amixer -c 0 cset numid=5 2,0,32768
amixer -c 0 cset numid=5 3,0,32768
#amixer -c 0 cset numid=5 4,0,32768

Anybody know what is wrong?


Re: Multiface II Feedback loop

Hi Tbrooke, I can't rule out a hardware problem here, but have you tried running hdspmixer yet?  It will at least let you return the multiface totalmix to an initial state, and let you determine easier if there is a hardware issue.  It does require running a window manager like KDE or Gnome...hdspmixer will let you route audio in your multiface in many ways that amixer cannot.  Totalmix, or hdspmixer in linux allows any input to be routed to any output.  Making amixer commands will not give you any insight into the settings in your mixer as they exist.  By default, inputs are routed directly to outputs but maybe that default configuration doesn't exist anymore.  It sounds like inputs 1 and 4 are routed to output 1 which is entirely possible given the open nature of the mixer and not a fault.  If you in the analog world are swinging around a live mic with speakers turned up in the same room who can help that?  wink  I guess I don't understand this testing configuration you are working with.

Hope this helps,

jonathan adams leonard